Error during installation's file copy (OS 10.6)

My wife’s computer got stolen so we bought a new-to-us Mac, and the first thing I tried was installing Scrivener 2.3.1. The OSX 10.6-or-later version downloaded from the site and opened the disk image correctly, and I dragged the Scrivener icon onto the Applications folder icon. The copy stopped halfway through with the error:

“The Finder can’t complete the operation because some data in “Scrivener” can’t be read or written. (Error code -36)”

It’s literally the second app I’ve added (after Dropbox) on the (Intel) Macbook’s default fresh install of Mac OS X 10.6.3. I’ve installed Scriv on four other Macs without a problem.

Get Info on the app in the disk image shows I have full permissions. I tried re-downloading the disk image with no change.

Any insight? (I’m next going to try an OS update, but that takes a while to download over our crappy Internet connection.)

Bizarre. Worked just fine after updating the OS to 10.6.8. Wonder if there was some freaky permissions issue the update fixed?