Error importing ODT files

I’m trying to get started using Scrivener to work on my dissertation, up until now I’ve been writing in Libreoffice. When I go to import a chapter from an ODT file I get an error pop-up:

(I’ve edited out the filename)

I know Scrivener can import ODT files, so I’m not sure what’s going wrong here. I use the dev version of Libreoffice, so I can edit certain DOC files that are sent to me. So I thought it might be an issue with files saved in the dev version of Libreoffice, but I tried opening files that were only used in the release versions of Libreoffice and I get the same error message.

Can anyone else import ODT files?

(I guess I could save as a doc and import? Haven’t tried that yet…)

Just tried to convert to DOCX and import with the same error, is Scrivener on Linux able to import files at all?

It can definitely import. I just tried from a very large, image rich, pdf and it all went fine. I haven’t tested ODT or DocX yet. If I get some time soon I’ll try both of those for you to see what I can find out.

I can proove that

  • odt
  • doc
    and docx files are not imported.
    Tried all of these.
    My workaround was “Copy and paste”.
    I think importing rtf files worked.


Another work around would probably be saving the file as a PDF as those are supported, or RTF (I just tested this so I can confirm that it is supported.).

Seems a bit poor that ODT and DocX files aren’t supported as of yet. This is beta though, we can’t expect a fine coat of gloss just yet.

Yeah, ODT importing has been broken for a bit. It used to work, but now it doesn’t. If you really, really need to import an ODT file, download the windows trial. It will run without winetricks or modification in WINE 1.7.20-current. (Don’t use the stable branch. It’s out of date.) That having been said, make sure you close your document on the Linux one first.