Error message on install release 1.0

I just installed the release version 1.0 of Scrivener for Windows and received an error during the installation process. All went fine until the program got to the check for the Visual C++ runtime. There was a pause and then an error message popped up. After I closed out the message box, the installation seemed to complete correctly. Tried to do a screen capture but it didn’t work, but here is the text of the error:

Problem running post-install step. Installation may not complete correctly. Error running C:\Program Files\Scrivener\resources\vcredit_x86.exe /q: Program ended with error exit code.

I had just uninstalled the beta, .046 I believe, so I apparently have already met the criteria for the runtime. I’ve never had any problem with an error like this on any of the betas and I’ve been using them since the first of the year. The Scrivener release version did seem to start up and run properly although I haven’t given it a good test. I just wanted to pass on this error.

Update: I should mention that I’m running Scrivener on a Thinkpad with XP SP3.

Gina

I got this error too on my Windows XP netbook but like Gina Scrivener’s been running fine with no issue so far.

Count one more. Same problem.

Charles

Same. Also running XP Pro and install was after uninstalling the trial.

Thanks!

Thanks for the notice, all! I’ve emailed Lee so we can get this checked out.

Same problem here.

It seems there’s a problem trying to run the Microsoft check and installer for the runtime files, so Lee’s going to strip that out of the installer. As long as you’ve gone ahead and installed the files (if you’ve already run an earlier beta, then you’ve got them installed on the machine, as Scrivener can’t run without these), just click through the error message and ignore it; Scrivener will finish installing properly and you can carry on using the program as normal. Sorry about this!

For me, the install hangs trying to verify the C++ runtime files, so there is no clicking through the error. My only option was to stop the install via the task window. Scrivener runs now, but occasionally crashes. I’d like to uninstall and do a complete reinstall. I’ve tried, but the install still hangs in the same place.

I’m checking on the update status for this one; hopefully downloading the release with this additional installer stripped from Scrivener’s installer will correct the issue for you once that becomes available–probably later today.

I’ve emailed support about the same issue. The post install process gives the error, but after clicking OK, it goes on to finish with “creating uninstaller”.

Scrivener runs, but the activation process errors.

two machines - ACER travelmate laptop and a “noname” desktop, both running XP SP3.

regards
David