[Error] Name Generator not found

Has the name generator been removed from the latest linux release? It was in the previous version, but now when I go to the name generator button in the menu, I get the following error:

When I went to see if this was a permissions issue, I found that the resources directory does not exist.

I’m actually not used to having the name generator work. I recall some instructions (from the wiki, perhaps, and possibly out of date) on copying over some data files from the windows version. But if you had this working earlier, there might be a more simple fix.

How did you install (or how are you running) your current version of scrivener?

I installed the Linux version. Untar then moved to the /usr/local directory.

I double checked, the actual name generator program is working, but the database that it uses to generate names is what is missing. It seems like they did not link it in the latest build.

I haven’t tried stealing the db from the windows version, but I agree that should just transfer easily over. Now to find a windows box…

You should also be able to grab the files you need from a WINE-based install on Linux. It seems the only one you need is called ‘alias’, and it’s identified by Linux as a SQLite 3.x database.

This worked for me on 029 (data from Windows 029 install to Linux 029):

sudo mkdir -p  /usr/local/LiteratureAndLatte/bin/resources/toolbox/namestool

sudo cp ~/.wine/drive_c/Program\ Files/Scrivener/resources/toolbox/namestool/alias /usr/local/LiteratureAndLatte/bin/resources/toolbox/namestool/

I’d attach the alias file here, but I can’t compress to smaller than 1.4MB (limit seems to be 1 megabyte).

Worked for me, man. Thanks. Next time I build a beta .deb, I’ll include it.