Error on upgrade of from RC19 to RC20

Installing upgrade
Getting:
Error copying file from packed archive, retry doesn’t fix it. Arg… feeling another uninstall resintall recreate some settings coming.

[PATH]/AppData/Local/Temp/Scrivner-29920-update-x64.exe to C:/Program Files/Scrivner/translations/qt_bg_qm.5392211

So I hit skip and it looked like rest would install not it has HUNG at QT5WebEngineCore.dll

Tried to download RC20 64bit from the forum link. Kept getting a failed network error. The network was fine.
So thinking previous installer download didn’t complete properly and left a connection issue.

Now have restarted the machine
Downloaded from Forum link and installed
That ran fine, but now have entries for both RC19 and RC20 in my Apps and features list
Both entries appear to be “live” vs ghosts that past RCs have created. Both feature active uninstall buttons.

My guess is once one uninstalls it will leave a broken or ghost entry. (I had just cleaned those out last week)

Not feeling “Almost there, when installing is unstable”

Hmm. I think I’m agreeing with you that your situation was actually a one-off.

And that was likely caused by original download problems or perhaps something else (some indication you hadn’t rebooted Windows in some time, which can also lead to mysteries starting to appear?)

I tried to duplicate your issue, and found that an ordinary within-Scrivener upgrade from 19 to 20 worked as expected.

However, first I ran into a series of problems which would highlight the item I know Tiho has on a do-later docket about the installer from me. Maybe should be added to his listing??

  • first thing I can say is, don’t ever try running Scrivener ‘as admin’ , if you log in normally as a non-admin following Windows security best practice.

This is what I had done to be able to run the in-Scrivener install procedure, which otherwise fails when you get to the actual install after downloading, as the installer lacks the proper permissions in this case.

The result if you try it will be to lose connection with all your settings, templates, etc; and if you try the update, it willl propose setting your Backups path under the admin login you passworded for, losing where you normally keep Backups.

  • The installer will also be locked from cancelling at this point, so you can only use the Task Manager to get out of it - not recommended to stop an installer for reasons we can appreciate – and no installer should put you in a non-cancellable situation.!

So what I did to attempt duplicating your problem was to change my login to an admin type, log out, log in, then run Scrivvener normally. At this point I could request if updates were available, and the recognition and install procedure worked fine from there, so that I did not duplicate your happinstance.

As a final note or two, the installer in this case properly requested I agree it was allowed, in the normal way. This shows that the installer Scrivener uses can do this – and so it shouldn’t be difficult to get it to do so when the original login isn’t admin-permitted, as is on Tiho’s docket already.

Wordjoy, hope this is all somehow helpful to your situation and cause :slight_smile:

Clive

I had no problem install from when the notification popped up saying there was an update. One thing I would suggest depending on your antivirus is by disabling it and see if it continues. There are some that seem to be blocking its install or usage.

Just a thought.

A) It might be a one off, they all are until more than people report. Like the Windows deleted my data bug last year. :slight_smile:
B) I have never elevated Scrivener (runs as Admin) and this machine was turned off this morning. Its also a pretty new machine that never had Scrivener before RC18. [Presidents Day Sale Victim here].

The one request even as a run off, is that the installer actively look for duplicate install entries and clean them up, as this has been a long term issue with the beta and appears to still be possible as we near release.

In general, one should pick a path (least-privilege install or admin install) with Scrivener for Windows and always use that method going forward, as it will install in very different places and have different behavior (as is to be expected).

If you are going to switch streams, you’re probably best saving your backups, files, and settings, then uninstalling the old version manually, then moving forward with installing the new version using the chosen method.

Updated Win 10 Laptop last night. No Problem
Updated my win 20 tower this morning. No problem

I agree, have done that for years. I’m not sure where people are getting in trouble to the degree of losing settings, but that’s probably good advice, though I’ve switched back and forth for testing a few times and not lost anything.

At the same time, I haven’t tended to customize too much (though increasingly), so that may be why I haven’t seen it.

Nevertheless, good advice indeed to save those Settings and Theme Settings away, if just for a rainy day [sic] :slight_smile:

(n.b. I did seem to lose settings actually yesterday in doing the above tests, but that was because the forbidden run-Scrivener-as-admin when it’s usually not caused the whole attempted install to be under the administrator target, rather than my normal user identity. Details few of us would want to know, hence the above…!