Error opening (Mac OS X) Scrivener project in iOS device

I’ve just installed Scrivener for both iPad and iPhone. I already have a project in Scrivener running on Mac. I’ve synchronized my project using Dropbox and I’m getting the following error message:

«Invalid project. The project cannot be opened because it does not contain a valid binder structure file»

iOS is 9.3.3 in both iPhone and iPad.
Mac OS X is 10.11.5
Scrivener is version 2.8 (26295)

I take it you’ve set up the folder location in settings in iOS Scrivener. (not the root folder of Dropbox)

Was the project saved straight out of Mac Scrivener to that folder location?

I have the same problem. I can sync from a new ios project to MAC, but not in the opposite direction, from Mac to IOS

I experienced this to start with. It turned out to be the result of the time delay in Dropbox syncing between my Mac and their servers (with a few Scrivener projects there were thousands of files involved. Once Dropbox had caught up on both my Macs I pressed sync on Scrivener iOS and waited again (at least one cup of coffee-making time).

Once all that syncing was done the projects opened properly.

  1. Yes. I set up the folder location in settings in iOS Scrivener. It’s not in the root folder of Dropbox, but in a specific folder where I save my Scrivener projects.
  2. Yes. The project was created and saved straight out of Mac Scrivener to that folder location.

I had the problem as described by McGuff early in the beta but don’t recall that message, but some time back.

It did take a while to do the first synch

Also, you might want to have a look at this set of fixes, which could help on a Project if one or both of them fits your case:

[url]https://forum.literatureandlatte.com/t/two-ways-to-fix-projects-that-convert-but-dont-open-yet-in-scrivener-ios/33918/1]

A possibly more user-friendly explanation of recovery steps is also now here:

http://www.literatureandlatte.com/forum/viewtopic.php?f=53&t=35143&p=217263#p217263

I am also dealing with this issue.

My projects show up, but an error box tells me they’re Invalid Projects without valid binder structure files.

I am getting this error on older projects and on a brand new project I created for the purpose of testing, thinking maybe the problem was with my older project files.

I have given it time to sync (two hours!) and have deleted+reinstalled the app twice. I have also restarted my phone.

I’m also getting the same error on my iPad. :open_mouth:

Any suggestions?

Same here and it makes me a very sad panda. My (quite recent) project opens fine on my iMac, but no iOS device of mine recognizes its binder structure. I don’t have any weird fonts or anything, only a few images downloaded from the web here and there.

It might be worth noting that my Macbook Air struggled with opening that project, crashing Scrivener regularly on open. I don’t get why, it’s nothing weird.

That sounds like there’s something wrong with your project, but the Mac version is able to struggle past whatever’s wrong.

Try creating a new blank project in your dropbox/scrivener folder, and then go to File->Import Scrivener Project and choose the problem project. Maybe by doing an import into a fresh project, the issues will be left behind and you’ll have something that your iOS version can handle…

Okay, reporting back.

I re-installed the app a fourth time. Restarted my phone again. Nothing. I synced again. No change. Restarted phone. Synced again. Poked my phone’s screen super hard because of reasons.

Boom. Suddenly, no more error. The files open. I don’t know what made it work, but it finally worked.

I installed the app around 11am and it is now 4:30pm. I’m disappointed in the experience so far, but I’m looking forward to using the app.

If you seen an error like this, it’s almost certain because your computer hasn’t finished uploading the files. Here’s what happens:

  1. You move the .scriv projects to the Dropbox/Apps/Scrivener folder on your computer (Windows or Mac). At this point, the Dropbox app on your Mac or Windows machines will upload all of those files to the Dropbox servers. How long this takes will depend on how big your projects are.

  2. You set up sync on your iOS device and hit “Sync”. It then downloads the files from Dropbox. It can only download the files that are currently available on Dropbox, however. So if your computer (from step (1)) hasn’t finished uploading the files, it will only be able to download incomplete projects. If you then try to open them, you will see an error that files are missing. Each Scrivener project contains many files, remember.

The key is always to ensure that Dropbox on your Mac or Windows machine has finished uploading or syncing before syncing on your iOS device.

In general, this is going to be slower the first time you sync, because the first time you move across a project or sync it on iOS, all the files for that project have to be uploaded or downloaded. When you make changes, on the files that have been changed inside the project need uploading or downloading, meaning sync will be faster after the first time.

All the best,
Keith

Keith, for what it’s worth, I have been making sure the Dropbox sync was complete (long-time user of the Windows version when you had to be extra careful when using Dropbox :wink: )

If everything is definitely synced and you still have a project encountering an error such as this, please zip it up and send it to support so that we can look at what is going on.

Thanks and all the best,
Keith

(my bold)

… and you literally mean Saved, using “Save as…” into the Scrivener folder in the Dropbox folder on the Mac?

Okay, rdale, thanks a LOT for that trick: it worked. I don’t know what was wonky with my older project but creating a new one and importing the old content fixed it. I am definitely keeping that trick in mind in case the same issue happens.

Keith, is that a common issue or are you interested in the original buggy project?

OK so I’m having the same issues. I’ve upgraded my desktop and iOS versions to the latest and when I try to open ANY of my Scrivener files, I get this error on my desktop. This is before I tried to sync anything with Dropbox.

When I move one of these files to Dropbox, and try to open in iOS, I get this error message in iOS:

Invalid project.
The project cannot be opened because it does not contain a valid binder structure file.
OK

Have you tried to do what the text in the warning box tells you to do? ctrl-click and so on?

Okay, this is all extremely frustrating.
I have renamed my project (because of the various versions) and trashed the old one from the desktop computer because it wasn’t needed anymore, and Scriv iOS just went all crazy when trying to sync. It keeps trying to recreate the deleted one, but ends up creating a corrupt file, blocking sync. So I tried deleting everything directly from iOS Scriv while keeping a backup of my project, but trying to restore that backup then gave me an error saying that “the file Settings does not exist” even though the project worked fine five minutes ago. I don’t want to yet re-import everything AGAIN in another project. Of course, I wait for it all to sync thoroughly before doing anything.

I re-deleted everything again, typed that post, thought “what the hell”, trying re-syncing one last time, and for some reason now it works…

Frankly, this feels incredibly wonky. This makes me very afraid that I might lose important work at some point, I feel like I cannot trust the software and use it in a production environment. I know bugs happen but frankly, this feels like it has not been tested thoroughly. So, for the time being, I will just leave the app to collect dust and not use it. I’m very disappointed.

The thing that makes it wonky is usually that people make one or both of two mistakes.

  1. They use “Sync with external folder” in the File menu, and thus create a lot of rtf-files instead of the Scrivener project which iOS Scrivener expects.
    Solution: Use “Save as…” instead.

  2. When they move the projects to Dropbox, they drag the project from Finder and dump it on the Dropbox [b]app/b, which creates zip-files.
    Solution: In Finder, choose File-New folder and create the folder you want for sharing projects with the iDevice in the Dropbox folder in Finder. Then you either drag and drop the Scrivener projects within Finder from their current location to the folder you just made, or you do as in 1).

And some do both. Then all hell brake loose… Megan M wrote this beautiful post, explaining all the steps in detail:

https://forum.literatureandlatte.com/t/comparison-to-other-word-processors-and-writing-tools/68/1