Error while compiling to Kindle: invalid KindleGen

Compiling to Kindle is driving me nuts. I don’t know why it keeps giving me an error. I used to do it on Windows and I had no problem.

Info about my device:
Software: OS X 10.9.4
It’s a MacBook Air, by the way.

I’m using Scrivener 2.5, which it tells me it’s the latest version available.

The problem is that when I choose compile to Kindle and I choose the path for KindleGen, everything seems normal, but when finishing the compiling it gives me an error like in the image attached, which basically says that my KindleGen is not valid. I’ve tried changing the name, the path, downloading it again… nothing works.

I’ve read the “read me” file on KindleGen and it says that you should open “Terminal” and drag the file to the window and then press enter. That’s what I do, but it says “permission denied” all the time.

I’ve changed the permissions on opening apps on my Mac, so it’d open every developer app, but it keeps giving me the same error.

What should I do? I’m clueless.

Thank you very much.

Btw, I’ve tried with a different project and it gives me the same error.

Does this article help at all?

scrivener.tenderapp.com/help/kb … -scrivener