Errors importing WORD doc

Hello, I am on Scrivener trial and just tried to import a WORD doc, but when I open in Scrivener the doc has odd errors, it contains old edits merged with new ones. eg: ‘The brown cat sat on the mat’ which say I had edited to ‘The black cat sat on the mat’ will display in Scrivener as ‘The brownblack cat sat on the mat.’

Could it be to do with tracking changes settings? Or maybe corrupt WORD doc?

Is WORD 2002 SP3 and Windows Vista.

Any help much appreciated. I did try to import as RTF as well, but same errors.

Many thanks!

Yeah, that sounds like a change tracking problem. Make sure to apply changes before importing into Scrivener. Our importers do not support change tracking.

Thanks for getting back so soon, no, the changes have been applied and saved in WORD doc, a while ago! Am more wondering if there is a tracking changes setting that I am unaware of that has caused these glitches in Scrivener doc…

Hmm, thinking of a free way to try and fix this file, what if you open it in OpenOffice or LibreOffice, and then save the RTF from there and import the RTF into Scrivener? That could potentially weed out any weirdness with the .doc file that Word itself is propagating into the RTF when saving it from Word. Copy and paste might also work from Word, if the changes have been applied.

Hey, Still getting the errors, have tried every poss way of saving! I think I need to just ditch this (long!) document and start afresh. Thanks again for your suggestions.

If you save as a .txt file from Word, do you get the same result? That would of course drop all of your formatting, but it would at least save you the time it took to key it all in.

I doubt this will make any difference, but one other thing to try if you haven’t is switching the converters Scrivener is using for the import. In Tools > Options under Import/Export, toggle the option for using the Microsoft Word converters and try the import again.

If that doesn’t work, would you be willing to send a copy of the problematic file for my attention to AT literatureandlatte DOT com with a link and reference back to this forum thread? The problem does sound like it’s stemming from the track changes issue, so there’s probably not a lot we’d be able to do, but it’d be good even so to get a sample file that’s causing some trouble in case we’re able to work with it to improve import. It needn’t be the whole file; just a sample portion that’s demonstrating the problem will be fine, if you can point out where the problem is occurring on import. Thanks!