eSellerate install failed with error: -2003

I’ve used Scrivener for years—starting when it was called Scrivener Gold—and have found it to be incredibly problem-free. I’ve never had a problem. However, I just updated to 2.4 today and got the “eSellerate install failed with error: -2003” message. Apparently this problem has a history as I found a support article for it and dutifully got rid of the EWSMac.framework file from both libraries and the MindVision folder as suggested.

I re-installed Scrivener and I’m getting the same error. I thought I’d post here before bothering support in case there’s something I’ve missed.

Anyone know what the next step might be in resolving this?


Yep. I’m in the same boat. Scrivener ran the 2.4 update this afternoon and now I’m locked out of my registration. I ran through the “eSellerate install failed with error: -2003” tutorial - twice. But unlike rossignol I didn’t have EWSMac.framework files in either folder so I’m not sure what the hangup is. It must be something different than the historical problem. Please fix me. I have writing to do!


Same boat, with a difference. Got the eSellerate error, followed the procedures in the trouble-shooting instructions (though finding EWSMac.framework was a bit of a sleuth, as it turned out to be not a file but a folder), and reinstalled. Opened without a hitch, recognized my user name and all that, and I was able to reopen a project, insert an anxious author’s burning changes into a manuscript and export in Word to a calendar-eyeing production department.

So far so good. But there does seem to be something hinkey about this update, with two (so far) landing in the heart of darkness and me, so far, finding a clean, well-lighted place.

There’s nothing hinky about the update, but it does include updated eSellerate files for registration that have to be installed on your machine. This error occurs when you have permissions problems on your machine. It is annoying, definitely, but unfortunately it’s out of our hands since the issue is with users’ machines. If you follow the instructions, it should be resolved (the EWSMac.framework is definitely on your machine else Scrivener never would have been able to run). If you follow the instructions and still have issues, please try everything on this page: … read-first

And then: … all-failed

Okay, I’ve fixed it on one machine (my office iMac). The EWSMac.framework folder was actually in Me/Library/Application Support/eSellerate/[some numbered folder]/EWSMac.framework. I must have missed it the first time. I’m hoping the same will work for my MBP when I get home.

This means that the directions are incorrect. They should specify the eSellerate folder in Application Support Folder rather than the other one specified. Or is it both?

Unfortunately, this update and the fiasco with it comes at time when I am trying to meet a deadline for the number of words written in one month. Not good.

I am not happy with this at all. I never had a problem with any updates and have loved my Scrivener, that is until this update.

This is NOT an issue with my computer but an issue with eSellerate and their system. They need to correct the problem.

My permissions are repaired. I have followed all of the instructions. I even ran DiskWarrior about three days ago. So that means this is NOT my issue or my problem. I even got rid of the file under the Application Support Folder and still I receive this error. :smiling_imp: :imp: :cry:

I had this same error and if you follow the instructions it will resolve the issue. I had to do it twice because I had a backup disk attached and forgot about the additional file. If you use something like “EasyFind” and look for all EWSMAC.Framework files, it makes life easier.
Just make sure Scrivener is not installed, delete the EWSMac.Framework files, reinstall and Voilà!

Sorry, I should have been more specific about the search. I used “EasyFind” from DevonThink Technologies. Available as a download from them or at the App Store – it is free. A great search app that will really make life easier.

P.S. I am in no way connected to DevonThink. I am a 75 year old fan of technology and “writer in progress” who appreciates great software–like Scrivener and Scapple!

Well, that is not true for me. I followed the instructions and did it twice. No luck. I even went to the eSellerate site to see if there was a solution there. No such luck.

I opted to go back in the Time Machine before the update. I guess I will never be able to update my Scrivener again due to eSellerate’s issue.

And I might have to find other writing software. This update has been a huge disappointment.

Whoops, “EvenThink” should be “DevonThink” (Well I told you my age…)

Repairing permissions using Disk Utilities is not going to fix it. Deleting ALL EWSMAC.Framework files is the only way to fix it. If you set “EasyFind” to look for EWSMAC (showing invisible files) and “Files only” “all words” “ignore case” it will find all instances of those files. Delete them, Remove them from your trash and reinstall. Be sure no copy of Scrivener is present and your trash is empty.

All of those files have been deleted. Done.

Trash empty. Done.

Getting into Scrivener. No deal.

I fail to understand why this update is not available in the App Store. It would solve many problems. Version 2.3.1 is available in the App Store.

To be sure I understand:

  1. You uninstalled Scrivener and emptied your trash; then,
  2. You found and deleted all instances of "EWSMAC.framework; then,
  3. You emptied your trash; then,
  4. You reinstalled the updated version of Scrivener which you download from Literature and Latte website ; and,
  5. Opened and got the same error?

P.S. If you bought it at the App store, it will not work. You will need to wait for the upgrade from the store.
I think you can run it for 18 days as a trial?

We have no control over when Apple approves software updates on their store. The best we can do is give them the update and then wait, and often they’ll come back and say this or that widget isn’t right and it has to be fixed, uploaded again, and it starts all over. We used to do all of this behind the scenes and everyone would have to sit on the older version even though we had the direct-sale one ready to roll. But we’ve taken a policy of uploading both at the same time. This works in favour of everyone, in the end. The people who purchased the MAS version aren’t getting the update any slower than they would have otherwise, and meanwhile everyone else can start using the new version that is already available. This means more people can help sort out any early bugs that missed QA, which improves the quality of the MAS version once it goes live (important, since rapid fixes to problems are next to impossible).

If you have run through all of the troubleshooting steps and nothing is working for you, then please contact eSellerate’s support, or if you would rather you can contact us and we’ll set up a ticket for you (but the former will be faster, naturally).

I got the error but followed the instructions and it was fixed in under 5min. The link to the instructions from the error message was VERY helpful. Had you gotten a lot of those issues when beta testing and prepared accordingly, or is it an old issue you’ve been prepared for for some time now? It’s kinda strange that I had a permissions problem considering I fairly recently ran a permissions check on my machine and fixed everything there was. Oh, well.

Either way, thanks Scrivteam for the streamlined help with the error!

Yes, fortunately this problem came up in beta so we were well prepared for it as we had time to test the provided solution and verify that it solved it for everyone (there have been a few outliers, but these appear to be caused by secondary problems that likely would have cropped up anyway eventually, even without the update). If I remember correctly, the problem only impacts those that have upgraded from 10.7 to 10.8, though perhaps some incremental OS X upgrade messed up permissions as well. So it is unfortunately rather broad, and since it is something OS X does itself, there isn’t a whole lot that can be done short of making the self-help info as good as possible. Glad to hear it worked well for you.

10.6 to 10.7, I think; I got it running Lion. And we all know how smooth an update Lion was. :unamused:



I’ve just fixed it on my 2nd machine (MacBook Pro). I think the problem—for me at least—was that the instructions neglected to mention that the EWSMac.framework folders (not files) were (might be?) in three places: Macintosh HD/Library/Frameworks; User/Library/Frameworks; and User/Library/Application Support/eSellerate/[a file name with numbers only]/.

I’m still a bit unclear about the cause of all of this.

If it is a permissions problem, then were permission magically fixed by getting rid of the EWSMac.framework folders and having them replaced by fresh ones from the reinstall? And if it is an issue with users’ machines, as Keith suggested, then I’d want to know what caused the problem. Obviously it was something in the updated eSellerate files for registration that caused “the issue on users’ machines,” which I’d call a symptom rather than the real problem.

I have now performed the set of instructions THREE TIMES without resolution. I still receive the Error -2003.

The solution does not work for my computer. Who knows why? I am mystified.

I wrote an email to Literature and Latte and to eSellerate. Both are now aware of my problem.

I am NOT some fly-by-night Mac computer owner. I have owned Macs since 1994. I have taken them apart down to the walls and rebuilt them. So this is not like I do not know what I am doing. Troubleshooting is one of my favorite past times on my Macs. I solved a major problem on my spouse’s Mac about three weeks ago.

Disk Utility helps with permissions on the computer after new software has been installed. I use the utility software on a regular basis.

Again, I will return to the former version through the Time Machine until such time that this problem can be fixed. And I will seriously think of finding software without this problem. I have encountered strange problems before and resolved them, but nothing this frustrating.