Excluding a document from compiling in binder

Hi. I have a feature request:

It would be nice to be able to select a document in the Draft folder of the Binder and indicate that you don’t want to include it when you compile. You could do it by right-clicking and selecting “Do not Include in Compile.”

Then there could be a visual indication in the Binder that the document isn’t going to be compiled.

I know you can uncheck the Include checkbox after choosing Compile, but it would be nice to also do it in the Binder.

Okay, I just realized there is an “Include in Compile” checkbox in the “Define Meta-Data Fields…” section of the Inspector.

I still think it might be nice to see an indication in the binder. There could be a little red dot or a tiny “x” to the left of the document icon.

What would you propose to do for those documents excluding explicitly during compile? File > Compile then Contents panel with its Include button for every document/folder. Should those have a red dot in the Binder too as those settings are sticky (aren’t they) and if one uses Custom Compile format presets then there is massive opportunity for ambiguity with documents being included in one preset by excluded from another.

I much prefer to control what is or is not in the active Compile by selecting/deselecting those buttons rather than messing about with Inspector flags that can so easily be forgotten.


Yeah, I am proposing that documents excluded in File>Compile will also have an indicator in the binder showing they aren’t going to be compiled.

I don’t think it will be too confusing.

I hope Kevin will chime in to see what he thinks.

I think otherwise. I use Collections for Compile and they don’t contain all documents. There are so many variants that every document would, as a result, have to be marked as excluded, which defeats the object of putting an indicator on the Binder entry.

Actually, I just realized I can pretty much already do what I want:

I created a Label called “Do Not Compile” with a red color.

Then I assigned that Label to some of my documents; I also had “Use Color Label in iCons” turned on so those documents were tinted red in the binder.

Then when I chose Compile from the File Menu, I created a filter to exclude documents with that Label.