Export crashing

I’m fairly new to Scrivener, but I didn’t find any answers to this using the search option here.

I have a project that won’t export (draft). Whenever I try, Scrivener hangs, and has to be force-quit. I can export the tutorial that came with Scrivener just fine, so I expect there is something in my project that is causing the problem.

This problem happens when trying to export the entire draft, or just certain sections.

My project isn’t huge, ~23,000 words, and it should all be text. The info under “Research” is also all text. Most of this data was imported from .rtf files created in NeoOffice.

I tried waiting overnight to see if it was just slow, but it was still hung in the morning. Scrivener has NOT created a crashlog. Everything else seems to be working perfectly (and wonderfully, wow, what a great program!)

The only non-standard things I can think of are these: 1) I installed it into a folder under Applications, and 2) I renamed the topl-evel “Draft” name to my project name. I changed it back to “Draft” after seeing this issue, but alas, the fix wasn’t so simple.

Scrivener v. 1.0.3, bought just a few weeks ago.
OSX 10.4.9, fully patched, on PPC chip.

I’m pretty computer-savvy, and am happy to trouble-shoot (via here, IM [AIM: a l l o c h t h o n 2] or e-mail). And I would be happy to send the file to someone for testing. I’d rather not re-import, but I can copy/paste it all out and back in if necessary.


Try downloading the 1.1 beta from the Beta Testing forum. Make sure you completely delete any 1.03 versions of Scrivener you have hanging around, as 1.1 will update the file format and if you try to open new 1.1 files on pre-1.1 versions of Scrivener, the files could get corrupted (though back-ups will be created automatically, so all will be retrievable). Hopefully 1.1 fixes this. If not, let me know (in fact, let me know either way :slight_smile: ).

It is still crashing. (1.05b2)

The progress bar gets to 100%, then the mouse starts to spin. Nothing is created in the destination folder. Still no crash log created.

The updating of the file structure seems to have gone just fine, though. =)
Thanks, Keith!

The contents of Research should not impact draft export at all, it doesn’t even use it except in the case of MultiMarkdown image linking.

Something you could try is selecting everything in the Binder, and then pressing Cmd-Shift-E to export files (as opposed to draft). This will create a bunch of RTF files and whatever else you have in your project, in the specified folder. Then create a new Scrivener project and drag everything from this folder into the new project.

Anything interesting in the Console?

Have you tried exporting using different format options, say HTML

Could you zip up the file and send it to me at support@literatureandlatte.com? I won’t read anything in it, I just want to track the bug. Thanks!

On its way.