Export - MS Word - Margins problem

Hi-
When I compile my Scrivener to Microsoft Word the margins are too far right, i.e., there’s very little blank space on the right side of the document.

Here are the page settings on my most recent compile:
-Page Setup: Use project settings
-Compile for: Microsoft Word 97-2004 (.doc)

Any idea what might be causing the problem? Thanks.

You can adjust the margins using either the project Page Setup commands at File -> Page Setup, or the margin settings in the Compile dialog. Have you tried doing that? What happens?

Katherine

Thanks for the suggestion. When I try via Page Setup (and select Scrivener from the pull-down Settings menu and then enter my desired margins), I still get the same result, i.e., no blank space on the right margin.
page_setup_scriv.jpg

When I try via the Compile option, I also unfortunately get the same result.

What else might I be doing wrong? Thanks!

Just to be clear, are you seeing the problem in Word’s page preview mode, or in the actual printout? What happens if you use the File -> Print Current Document command to print directly from Scrivener?

In either case, what size paper are you using, and do Word and Scrivener have the same paper size setting?

Katherine

I’m looking at in Page preview mode.

Did you set a right indent? If so that would be causing the text not to wrap at the margin but instead go all the way to the set indent, presumably past the margin in this case. In the Formatting tab of Compile, if you are set to override text and notes formatting, click into each row set to include “text”, then click into the text element in the preview area below and check the ruler setting. The right indent marker should be affixed to the right edge of the ruler (so if you expand the window, it should continue to stick to the right edge). If it’s not, use the mouse to drag it off the right edge of the ruler–it will go to the right edge and stick there, effectively disabling it so that the words wrap at the margin.

If you’re not overriding formatting in compile, you’ll need to set this in the editor. First check that your default settings don’t include the right indent by going to the Formatting tab in Scrivener > Preferences and adjusting the ruler as above. You can then select all your documents and use Documents > Convert > Formatting to Default Text Style to convert them to the default; however, if you have other special formatting you don’t want to override by that command (excluding character formatting like bold and italic, which does not get overridden), you could do this instead by loading all the documents in a Scrivenings session, using Select All, and then adjusting the indent marker in the Editor ruler (Format > Show Ruler).

Thanks for the suggestion. Unfortunately, I still can’t seem to fix it. – As a work-around, I’m copying and pasting the document into Text Wrangler and then pasting it into Word and then doing all the necessary formatting :frowning:

Again, what page size are you using? You might see strange behavior if the Scrivener page and the Word page didn’t match.

Katherine

What happens if you export to RTF, rather than DOC format, and then open the RTF file using Word?

Katherine

Still same problem. However, when I compile the entire document, then the margin problem doesn’t happen. So even though I only want to export one section in my Scrivener document, as a workaround, I’ll compile the whole thing and then just take out that one section that I want.

I was hoping that the Export settings would inherit from the Compile settings, but I guess not (or there’s some detail that I’m overlooking).

Thanks again for your suggestions, I really appreciate it :slight_smile:

Is there anything special about the section you want to export? Is it formatted differently from the rest of the manuscript?

Katherine

No, it’s just body text.

To back up a bit…

Does that mean that if you don’t go via Text Wrangler, you get the same problem when pasting directly into Word? That would suggest that the problem is with the way the text is formatted in the editor, and not with compile settings or such. If you click into one of the paragraphs in the editor that is showing this margin problem, does the right indent appear correctly in the editor ruler (Format > Show Ruler)? It should move if you make the window wider or narrower.

Do you have another sample of text that does compile correctly? If so, try clicking into that paragraph and then using Format > Text > Copy Ruler, then selecting an incorrect paragraph and using Paste Ruler to see if that changes anything.

Does the trouble only happen when you use File > Export? That just makes a copy of the file exactly as it is in the editor, so the formatting isn’t getting cleaned up at all based on compile settings. It will use the margins set in File > Page Setup.

You can compile just a portion of your draft by selecting the container (e.g. the chapter folder) from the drop-down menu in the Contents tab of compile. You can also just whip off a compile of the current binder selection this way.

Yes; unfortunately, I still couldn’t fix the problem.

Yes. And thanks for the tip on the Compile options.

Since the original Scriv file that I was having these margin problems with wasn’t that big (in terms of number of sections, total words, etc.), I just decided to start from scratch.

  1. I saved and backed up the text in a separate application (TextWrangler)
  2. Re-set my Scrivener Preferences to the Default settings
  3. Created a new Scriv file and pasted the sections back in
  4. Saved it as a new doc
  5. Problem solved; no margins problem.

P.S.: This is just a guess, but one of the Scriv pages that I was having the Right-Margins problem with had a horizontal line/border in it. So I wonder if I didn’t use the horizontal border in my Scriv editor, the margin-problem would not happen when I exported to MSW. Just a thought.

Thanks again for all your feedback and help. :smiley: