Export Problem

I’m using Scrivener with my co-author.

(See [url]https://forum.literatureandlatte.com/t/multiauthor-multicomputer-projects/16357/1])

We have been exporting individual chapters, along with their meta data and notes, sending them via Dropbox, reimporting the main file, and then cutting and pasting the notes and meta-data. It’s pain, but it works.

However, I don’t seem to be able to export anymore. OR, more correctly, I can apparently export the metadata and the notes file, but I can’t get a file of the actual work. I’ve got to copy it, paste it into Notepad, and save it as RTF in order to send.

Which is BEYOND a royal pain.

Is there some setting I might have inadvertently changed which is preventing me from doing the export?

I select the chapter, click on File => Export and Save. If I select export Metadata and Notes, and then Save, I get those, but no main file. If I do not select Metadata and Notes, I get an error message saying “No files exported.”

Bumping this up to see if I can get an answer…

What are your export settings?

I cannot see any setting that would stop export in the options window. There are import/export options in the General tab, but they mostly affect importing documents.

Can you explain your export process in more detail. The more detail you provide, increases the chances that I maybe able to recreate this. Hopefully Jennifer and Ioa will see this soon and be able to help.

There’s a bug currently with exporting imported* files to .rtf–this gives you an error message if you’re just exporting the file, but I see that if you’ve selected to include notes or meta-data, they’ll export and there’s no message about the main file failing. This is on the fix list; in the meanwhile, you should still be able to export those files to other formats like .doc, so perhaps that would work for you?

  • This means that the original file was imported, even if you’ve since edited the goodness out of it in Scrivener.

How do I explain what the export settings are?

I select the file I want to export.

I click on Files => Export => Files

I get the export dialog and select where I want the files to got and select meta data and notes. It is set to RTF.

I click yes, or continue, or whatever it is, and get an encoding dialogue, for which I say “system” and click continue.

A which point, I get an error message saying no files exported. I have done screen shots if I can figure out how to upload them on this system.

Yes, all my files were imported to Scrivener from Word.

And yes, I can export (I just tested it) the meta data and notes as RTF and by selecting .DOC as my export, the main file will export.

I attached (if I did it correctly) screen shots to the message prior to this one. They look odd, though, so I may not have done them correctly.

It’s odd, because the first dozen or so times I did the export, it worked just fine going out to RTF. And then all of a sudden, bang, it didn’t want to do it any more.

May I beg on bended knee that if this is, indeed, a bug I have stumbled upon, that it be mashed flatter than a cock roach under a ten ton truck? This is something we’re going to be doing a LOT of since we are swapping files between the two of us, and there isn’t (yet) a way to export main file, meta-data and notes as a single compilation which can be re-imported into Scrivener.

I suspect my co-author and I are not the only ones swapping files back and forth.

Many thanks for your time and consideration.

Yes, this is the bug you’re seeing; it’s on the list to be corrected, like I said, and hopefully Lee will manage to get it in the next update, though I know he’s working on some other big issues like the lag problems right now. The RTF export was working up until I think the 1.0.3 update, at which point adjustments to something else accidentally broke it, so that would be why you were able to do this earlier and then suddenly ran into this. We’ll get it fixed as quickly as we can!

As long as I have a work around, and it’s not something I did to break Scrivener, I can cope. However – and I don’t know if this gives you any information on not – I started using Scrivener with 1.03 (the latest release), and it worked fine for a couple weeks. Then one night, it just didn’t want to work.

Bringing code up to where it doesn’t trip over its own feet is never easy. I will send best wishes to Lee for clear thoughts and easy logic chains!

Talking to myself, sort of…

I’m hoping there’s a fix in the offing for this problem.

I had the problem referenced above back in February. A work around was achieved by changing the export from a Word .doc file to a .rtf file.

This has worked for three months.

I did an export this afternoon… and Scrivener happily exported the metadata file and the notes file, and did not export the primary document. I did carefully check my settings, and they were correct for what worked before.

I do hope there’s a fix in the offing.

Today’s work-around was to copy everything out of my working window, paste it into Word, format it again, and save it as a .rtf file.

But it’s annoying. Did I mention I do hope there’s a fix in the offing?

No reply.

Bumping this up.