Export to Word fails on italics (bug or user error: you decide!)

Hey friends.

Wrestling with a weird thing (3.0.1 (996) for OS X).

When I export a project to Word format (docx), Scrivener selectively ignores italics. Let me show the master vs. the output.

Here is output where it works:

Here is the source of that segment:

Now, let’s get weird. Here is it broken:

But here is the source for that segment:

I’m not sure why it’s doing this.
It doesn’t appear to be related to single words vs. whole sentences.
It doesn’t appear to be related to punctuation at the end.
It doesn’t appear to be related to carriage returns

Not sure what is causing this. Manually editing a manuscript to put the italics back in is a bit of a pain, so an export fix would be awe-inspiring. Any ideas what I’m doing wrong?

Hey friends. This one’s starting to kill me; got an 85,000-word document to compile, and going through that by hand will be brutal. Anyone got any advice?

Are these lines by any chance styled? Normally a style would pass-through the formatting, but not if you specifically tell it to do otherwise in the compile Format. A quick and easy test of that theory would be to select the “Default” format and leave everything unassigned to print “as-is”. If that works, you know it’s a compile setting issue—if it still doesn’t work, I’d examine font usage next. The font looks the same, but are italics always being used, or have you sometimes used oblique—some fonts give a choice.

They aren’t styled, no. I don’t use styles in my work because I don’t need 'em, just type into the MS and hit e.g. italics for when I need them. This is what the style bar says over the selected text:
Screen Shot 2018-03-19 at 10.32.19 AM.png

They’re all italics. I wouldn’t know how to use oblique :slight_smile:
Screen Shot 2018-03-19 at 10.33.20 AM.png

However, the good news is it seems to be fixed. I updated to 3.0.2 (1506) and it now compiles successfully. I’m posting this in here to show anyone who stumbles across this problem after me that a new Scriv version fixes it (or seems to, for my MS), so an update might be the balm for your pain :slight_smile:

Strange! Well, glad it’s all sorted now. :slight_smile: