Export with KindleGen bug.

This is not so much a bug on your end, but a heads up for you.

Under compile, if you select E-book options -> KindleGen Options -> Check “Do not allow the readers to copy and paste the text,” you will get the error "<filename.mobi> doesn’t exist.
If you have KindleGen output a log file, it states that “nocopypaste is an invalid argument.”

This is with the latest KindleGen 1.2 build 33307.

Uncheck the box and KindleGen works fine.

Hi,

Thanks, yes, this is already fixed for 2.1. It seems that for some strange reason Amazon dropped the “no copy/paste” argument in KindleGen 1.2, so we’ve had to remove the option. Until 2.1 is out the fix, as you have discovered, is to ensure that box isn’t ticked.

Thanks and all the best,
Keith