exporting broken Korean docs

I changed my macOS 10.14.2 first system language from Korean to English to Korean. After that, when I export (or compile) a korean document in scrivener to .doc or .odt format, all the Korean characters in exported files are broken (looks like a lot of empty squares).

In detail, What I did was like this (step by step):

  1. My macOS system language was Korean. Then I got no problem with exporting korean documents to .doc or .odt
  2. For some reason I had to change the system language to english. I exported my korean document to .doc format. When I opened that .doc file with MS Word for mac, all I can see is broken characters (squares).
  3. So I restored system language to korean. I tried the same process and got no difference. Still got the same broken characters.
  4. All my korean .scriv files produce broken exporting results now.
  5. exporting to .rtf format works as good as before. Doc, docx, odts are broken with same pattern.

Is there any trick I can try? or should I wait for your next update?

Does

https://forum.literatureandlatte.com/t/korean-text-goes-tofu-while-compiling-to-word-on-v3-1-1/43264/12

help at all?

:slight_smile:

Mark

I followed that instructions above but nothing changes.

First I installed Java downloaded from Oracle site.

And toggled-on the option.

But while I exported korean document to docx, fileconverter icon looks like this…
스크린샷 2019-01-12 오전 11.57.39.png

and the result was same. Nothing changes at all.

And this problem is not my system specific one. My friend who run scrivener 3.1.1 suffer from the same problem. His converting was OK before 3.1.1 (He tried the trick above too)

I found no simple workaround elsewhere and I’m waiting for some patch (sooner the better of course :wink:

The simple solution is to compile to RTF and open that in Word to let Word do the conversion to .docx and save the document in its native .docx format. RTF is a format originally created by Microsoft and in my 12 years of using Scrivener, Word—whether on Mac or Windows—has always opened my RTFs perfectly … though I only use English and Chinese, not Korean.

RTF is Scrivener’s native format, so when you compile to .docx, Scriv first compiles to RTF and then calls the third-party Aspose converter to convert the RTF to .docx. As that thread explains, there seems to be a problem with the Java used by the converter.

By compiling to RTF and opening that in Word, you are avoiding use of the Aspose converter. If you don’t have Word, Open Office and its variants also open RTFs, but use the Aspose converter, I believe, to convert them to .docx or .odt.

Hope that helps.

Mark

Could you please provide a simple sample project so that I can test?

Thanks and all the best,
Keith

Here are a zip that contains scriv, rtf and doc from one project.
The rtf document is OK but .doc one shows broken characters.
korean_sample.zip (56.9 KB)

Thanks a lot for the info and detailed explanations. That’s exactly how I write and get final draft documents since the problem happened.
(In spite of this workaround, I hope that java-related bug be solved soon so I can save some clicks and speed up my work steps…)