Exporting Research contents cos of (?)overload

Help! How do I move the entire contents of my Research folder OUT of Scriv altogether and back into my regular computer files? I want to just have this stuff in an ordinary desktop folder instead because I have so much material in the Research folder that it’s now slowing the entire programme down (at least that’s what I think is causing this problem): Whenever I type, there is often a four or five second delay before anything appears on the screen - a particular hassle when I have to correct typo’s or change things. You can imagine how disruptive this is to the creative thought process to have to wait out these halts before being able to continue! And they happen more often than they don’t, a sort of mini-“freeze” of 4 or 5 seconds.

This doesn’t happen elsewhere on my computer (a MacBook laptop running OSX 10 . 6 . 8 and it only started recently with Scriv when I moved a bunch of stuff into it, so I think I’ve probably overloaded it. The entire project weighs in at about 870mb, and really I can keep the media stuff elsewhere on my computer because it’s only for reference. I work only in text.

I’ve tried everything I can think of but haven’t figured a way to “export” or copy or drag/drop the stuff in my Research folder to my Desktop and don’t want to just delete it, so how do I get it out of Scriv and back into my normal computer files? This is causing me serious hassle, and finally yesterday I just went back to working in a word-processor simply to get the typing to flow properly. What do I do? Thanks! Bonnie

Hi Bonnie,

To answer your first question, just select the files you wish to export in the binder (or select the folder containing them) and go to File > Export > Files…

However, the number of research files in the project should not cause any slowdown, as they are only loaded into memory as and when required, so my guess is that something else is the culprit:

  1. Do you have any external services such as SpellChecker installed that might interfere with typing?

  2. Do you have lots of images contained inside text documents themselves (as opposed to being stored as separate image documents in the binder)?

  3. Which version of Scrivener are you using?

Thanks and all the best,
Keith

I couldn’t get File>Export>Files to work. It only gave me options that didn’t apply, like other places in Scriv, or filetypes that weren’t right. I tried all the options and nothing would move them out onto the desktop. And the closest (HTML) didn’t do anything either. I really did try a lot of things, but if that’s not the problem I don’t want to waste my time moving them!

I’m using Scriv 2.1 (14118). No, I don’t have any external services enabled and I don’t have pictures in actual text documents. They’re just in Research in their original form, from web pages or JPGs or GIFs etc. I can move ALL the pictures out of Scriv and keep them elsewhere if need be, since my project is text only and doesn’t need images, but as I say, I tried the suggestion above and it didn’t work, and I don’t want to delete anything. Also, that’s only a workaround and I’d really rather fix it.

I should also mention that my computer’s fan starts whooshing like crazy (which it normally doesn’t) when I use Scriv, and it really seems that whatever extra work the computer is having to go to that makes it get hot (which is what I guess is happening - sounds like it) could also be related to the delayed typing. Scriv also takes forEVER to close, forever to emerge from its zip file, and forevereverever to copy onto a stick drive.

File > Export > Files… is definitely the way of doing this - trust me, I’m the developer! :slight_smile: When you select that, you get a save window with these options:

Note that your research files could have notes and index cards attached to them in the inspector, so there is an option at the top to allow you to choose what format any text files included should use. But also note the bold print, telling you that all non-text files will be exported in their original format. So please just go ahead and use this, as this is exactly what you need.

[qutoe]I should also mention that my computer’s fan starts whooshing like crazy (which it normally doesn’t) when I use Scriv, and it really seems that whatever extra work the computer is having to go to that makes it get hot (which is what I guess is happening - sounds like it) could also be related to the delayed typing. Scriv also takes forEVER to close, forever to emerge from its zip file, and forevereverever to copy onto a stick drive.
[/quote]
Your project is nearly a gigabyte in size, so zipping it up would take a while - if automatic-back-up-on-close is ticked in the preferences, then it would therefore take some time to close while copying or zipping up a backup of this project (try compressing a gigabyte file in the Finder and you will see that it does indeed take time to compress large files).

That has nothing to do with the speed while it’s open, though. If the fan is kicking then clearly something is wrong somewhere - typing shouldn’t be enough to take up enough processing power to need the fan, and if that’s kicking in then that explains the lag. Have you tried quitting Scrivener completely and re-launching, to clear out memory? Also, have you tried restarting the computer?

While it is having these problems, could you please do the following?

  1. Open Terminal.app (from the Applications/Utilities folder via the Finder).

  2. Type “sample Scrivener 10 -file ~/desktop/scrivsample.txt” and then hit return.

  3. Immediately - literally as fast as you can - switch back to Scrivener and start hammering on the keys to simulate fast typing (the lag will be even worse while the sample is running, but that’s normal - make sure you do this when there is already a lag, though). Do this for 10 seconds.

  4. After ten seconds, go to the Desktop folder in the Finder and open the scrivsample.txt file that has been written there.

  5. Copy the contents of that file into your reply (you can then delete the scrivsample.txt file).

This will give me an idea of what Scrivener is actually doing while you are experiencing slowdowns.

Thanks and all the best,
Keith

Can I ask a potentially stupid question, please? Do any of your research files downloaded from the web include Flash material? I have found that the one thing that makes my MBA run hot and the fan go beserk is any Flash-containing website, though it seems worse with Safari than with OmniWeb.

Mark

[This is only a partial answer - I was just typing this before I saw your second post, so this first bit was written already, and I’ll answer the rest as soon as I have carried out those suggestions.] Just tried the file-moving thing again today, and yes, done individually the files DO move. Sorry about that! Is there any way to block-move the whole lot? But that’s one item off the agenda anyway.


Yes, I’ve closed & re-launched & rebooted numerous times, yesterday and today. As I say, I can always shift a lot of that gigabyte elsewhere, but that doesn’t seem to address the real problem. (I do have “save backup on exit” enabled.) The whooshing fan doesn’t come on unless I’m using Scriv, so something’s afoot.

I’ll now go do the things you’ve asked me to, and report back. Many thanks for the fast help - wish they were all like that!

Bonnie

D’OH! Posted before I saw Mark’s message (nothing stupid about it!) and yes, I do have a lot of Safari pages in there and they probably have Flash because what doesn’t these days?

If I take those pages out of there and only leave text in Scriv (which is honestly not a problem for me) do you think that would make this problem go away, i.e. if there were no Safari/Flash pages at all? I hadn’t realised about the Flash thing.

Bonnie

Hi,

To block move everything you can just select them all at once in the binder by using Shift-click or Cmd-click before exporting.

And d’oh, Mark may very well be on to something - I didn’t think of that. If you have any web pages that cause Flash to load, and if you have at all opened them during the session, then the fan may well kick in and slow things down. I get this in Safari all the time (although not so much since moving to Lion) - there’s part of the WebKit that Flash really slows down (this is why Apple refuse to support Flash on the iPad). Scrivener uses the same code as Safari (WebKit) for displaying web page content.

So try getting rid of the web content first and see if that helps.

Thanks and all the best,
Keith

OK, I’ve moved ALL the media content out of there, relaunched twice, emptied both Scriv’s & my computer’s rubbish bins, and switched off the whole laptop and let the machine cool and then rebooted. I’ve now reduced the Scriv programme size until it weighs in at a mere 64mb.

And the situation is better, but it’s still doing it! The fan doesn’t whoooosh so furiously but it still turns on and I still get the halting letters & general slow response when I type in Scriv, which doesn’t happen “outside” when I’m in Word or Text edit (both of which I use a lot).

So the problen is improved but not gone, and there are no Safari files left in there at all (I also had a YouTube I’d forgotten about but it had been there for ages and this problem is new). When I open & use Scriv, it does seem to set the fan going - something that doesn’t usually happen otherwise.

The next thing is to try Keith’s suggestions above, which I will do, but I have to give this a break for now and go get some of the work done which has been piling up while I wrestle Safari pages out the door. I also won’t get a chance to work on my book for a time, so will need to see how it goes.

Anyway, thanks for now!

Bonnie (who has been gruff & quirky since she was born…)

Just tried it again… (yes I know I’m supposed to be working…)

It’s actually just as bad as ever (tho I’m glad to have slimmed down the programme anyway for backup & saving purposes). Within a minute of typing I can hear the fan start up, then go harder, and the letters or keystroke commands hang for 4 or 6 or more seconds, multiple times per sentence. There’s no face icon blue enough to do me justice right now…

Anyway, I’ll try the other stuff when I get chance to -

I mean from opening up the whole programme from cold, and starting to type letters on the screen. When I’m not using it but doing other stuff, the fan doesn’t go and the letters do. Not sure if I made clear what I meant -

Please try taking a sample and posting it, as described above, so that I can see what is going on.
Thanks,
Keith

Clicktoflash is useful.

My apologies for the delay in replying, but I have been out in the big bad real world having to work, and I never get headspace for writing on those days.

The latest: After the hiatus I finally switched on again this morning to sketch out a new idea, and got the error message that Scriv couldn’t open the programme I was looking for because (??) it was already open in another copy (can’t remember the exact wording, but I haven’t been near the project since writing last, have had the computer off & on numerous times since, and there was definitely no other copy of it open). Scriv then asked me if I wanted it to “rebuild” its something-or-other (database?) and open a COPY of the programme so I could work from that, because otherwise I could lose some of my work (though I knew there wasn’t any open to lose). Fine, I said, Go for it.

It then presented me with my file bearing the project name, followed by -1 (signifying that it’s a copy, presumably), so I opened it and worked away, and have decided just to call the project by this new name with the -1 from now on, and not worry about where the “original” went.

I don’t understand why this happened because last time I was using Scriv - a few days ago - I had closed it down and relaunched it and then closed it down again, as well as rebooting the whole computer a bunch of times; and I left everything logged out when I switched off the final time. So it should not have thought anything was open - ??? (Maybe it’s Fate’s way of telling me I should spend more time Writing and less time Working? Naw… thought not…)

Be that as it may, I now have my project back, under its new name, safely duplicated on three external drives. I had the old one backed up too, and I always also export my text in Word files as well so I can access them independently of Scriv. So at worst it would have been hassle rather than disaster. Although I don’t know exactly what happened, it’s not a big problem for me. I’m just recounting it here to keep the story on this situation up to date and complete.

Re the “overload” I complained of above that slowed down Scriv (but not the rest of the computer): That situation, though not gone, is quite a lot better. Mind you, I didn’t use it for too long a time period today, which is unusual. I normally go on all day or for hours, up to now without problems. In spite of all the clean re-launches and entire reboots, maybe it was still somehow reading the old programme with all that Safari/Flash stuff in it, even though in the version I opened they were deleted? Don’t know, but I am now using this slimmed-down text-only incarnation under its new name, and although it does get a little whooshy and halts a bit, it’s nothing like as bad as before.

I don’t get to work on this project every day, so I think I’ll just live with it in its current form and see if after several hours’ use it gets bad again. If so, I’ll carry out the procedure Keith has outlined above and then report back. IF !!!

Thanks again for all the help! Bonnie

OK, still having the problem (though it’s not as bad as it was before I dumped all that content). Here’s that test sample that Keith asked me to do, though it had been worse before & also since. Hope this is what you want - sorry it’s so long! I also did a second one right afterwards so let me know if you want that one too, though it shouldn’t be much different as it was done around the same time; and it will also be too long to fit within the allowable message-size limit.

First sample gave me this text (which doesn’t mean anything to me):

[NOTE: THIS IS ONLY A PORTION OF IT: THE WEB PAGE SAID THERE WERE TOO MANY CHARACTERS & IT EXCEEDED THE MAXIMUM SO I HAD TO CHOP A LOT OF IT OFF. KEITH, IS THIS WHAT YOU’RE LOOKING FOR?]

Analysis of sampling Scrivener (pid 192) every 1 millisecond
Call graph:
7854 Thread_3384 DispatchQueue_1: com.apple.main-thread (serial)
7854 start
7854 _start
7854 NSApplicationMain
7854 -[NSApplication run]
7441 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:]
7440 _DPSNextEvent
7425 BlockUntilNextEventMatchingListInMode
7425 ReceiveNextEventCommon
7421 RunCurrentEventLoopInMode
7421 CFRunLoopRunInMode
7421 CFRunLoopRunSpecific
7413 __CFRunLoopRun
4750 mach_msg
4750 mach_msg_trap
2453 __CFRunLoopDoObservers
2411 _handleWindowNeedsDisplay
2399 -[NSWindow displayIfNeeded]
2398 -[NSView displayIfNeeded]
2379 -[NSView _displayRectIgnoringOpacity:isVisibleRect:rectIsVisibleRectForView:]
2338 -[NSThemeFrame _recursiveDisplayRectIfNeededIgnoringOpacity:isVisibleRect:rectIsVisibleRectForView:topView:]
2334 -[NSView _recursiveDisplayRectIfNeededIgnoringOpacity:isVisibleRect:rectIsVisibleRectForView:topView:]
2263 -[NSView _recursiveDisplayRectIfNeededIgnoringOpacity:isVisibleRect:rectIsVisibleRectForView:topView:]
2223 -[NSView _recursiveDisplayRectIfNeededIgnoringOpacity:isVisibleRect:rectIsVisibleRectForView:topView:]
2190 -[NSView _recursiveDisplayRectIfNeededIgnoringOpacity:isVisibleRect:rectIsVisibleRectForView:topView:]
2068 -[NSView _recursiveDisplayRectIfNeededIgnoringOpacity:isVisibleRect:rectIsVisibleRectForView:topView:]
1934 -[NSView _recursiveDisplayRectIfNeededIgnoringOpacity:isVisibleRect:rectIsVisibleRectForView:topView:]
1905 -[NSView _recursiveDisplayRectIfNeededIgnoringOpacity:isVisibleRect:rectIsVisibleRectForView:topView:]
1832 -[NSView _recursiveDisplayRectIfNeededIgnoringOpacity:isVisibleRect:rectIsVisibleRectForView:topView:]
1808 -[NSView _recursiveDisplayRectIfNeededIgnoringOpacity:isVisibleRect:rectIsVisibleRectForView:topView:]
1789 -[NSView _recursiveDisplayRectIfNeededIgnoringOpacity:isVisibleRect:rectIsVisibleRectForView:topView:]
1772 -[NSView _recursiveDisplayRectIfNeededIgnoringOpacity:isVisibleRect:rectIsVisibleRectForView:topView:]
1749 -[NSTextView _drawRect:clip:]
1737 -[KBBaseTextView drawRect:]
1737 -[NSTextView drawRect:]
987 -[KMBTextView drawViewBackgroundInRect:]
985 -[NSTextView(NSPrivate) _drawViewBackgroundInRect:]
984 NSRectFillUsingOperation
983 CGContextFillRect
983 CGContextFillRects
983 ripc_DrawRects
982 ripc_Render
979 ripl_BltShape
903 ripd_Lock
903 CGSDeviceLock
901 _CGSLockWindow
901 _CGSSynchronizeWindowBackingStore
901 mach_msg
901 mach_msg_trap
2 CGSDeviceLock
75 argb32_mark
74 argb32_mark_constshape
74 sseCGSFill8by1
1 argb32_mark
1 ripd_Unlock
1 CGSDeviceUnlock
1 _CGSUnlockWindow
1 CGSShmemGuardUnlock
3 ripc_GetColor
3 CGColorTransformConvertColorFloatComponents
3 CGCMSInterfaceTransformConvertColorComponents
3 CMSTransformConvertComponents
3 CMSColorWorldConvertData
3 ConvertImageGeneric
3 ColorSyncTransformConvert
3 ColorSyncCMMApplyTransform
3 AppleCMMApplyTransform
3 DoApplyTransform
3 CMMProcessBitmap(CMMConversionParams*)
2 CMMDataEncodeMaker::MakeFloatDataEncoder(CMMDataParams const*, CMMRuntimeInfo*, CMMColorSpaceType, unsigned long)
1 CMMFloatBitNChanEncoder::CMMFloatBitNChanEncoder(unsigned long, unsigned long, CMMDataParams const*)
1 CMMThrowExceptionOnError(CMMErr)
1 CMMProcessBitmap(CMMConversionParams*)
1 ripc_GetRenderingState
1 ripc_GetClipState
1 RIPLayerReplace
1 NSRectFillUsingOperation
1 -[NSTextView(NSPrivate) _drawViewBackgroundInRect:]
1 CGContextRestoreGState
1 CGGStackRestore
1 free
1 __spin_lock
1 objc_msgSend
463 -[KBLayoutManager drawGlyphsForGlyphRange:atPoint:]
463 -[NSLayoutManager(NSTextViewSupport) drawGlyphsForGlyphRange:atPoint:]
461 -[NSLayoutManager(NSPrivate) _drawGlyphsForGlyphRange:atPoint:parameters:]
223 -[NSLayoutManager temporaryAttributesAtCharacterIndex:longestEffectiveRange:inRange:]
162 -[NSDictionary isEqualToDictionary:]
63 -[NSDictionary countForKey:]
53 CFDictionaryGetValue
42 CFBasicHashFindBucket
39 ___CFBasicHashFindBucket1
20 ___CFBasicHashFindBucket1
11 __CFStringHash
5 CFHash

Bonnie, try attaching the sample file to a forum response instead of pasting it all in. Like you say, those files get very long. To attach a document, see below the Save/Preview/Submit buttons, there should be an “Upload attachment” tab. To save space, you might try right-clicking on the file in Finder first, and choosing to compress it.

Here they both are as attachments, which I’ve also compressed (I placed them Inline - hope that’s OK). Thanks! B

Scrivsample Bonnie 1.txt.zip (37.5 KB)Scrivsample Bonnie 2.txt.zip (94.5 KB)

Hi Bonnie,

The first sample just shows regular text view drawing going on; the second shows Scrivener saving. I’m wondering if it’s just autosave kicking in? Try going to the General pane of the preferences and extending the autosave period to, say, 10 or 30 seconds - see if that helps at all.

All the best,
Keith

But I’ve used AutoSave for years and it’s never done this before. This phenomenon is recent. I don’t really want to delay the Save and can’t see how it’s suddenly the problem if it wasn’t before…? Why should one of Scriv’s normal (and valuable) functions turn into a liability for no reason?

Not a liability, but if this project is large it might take a while to save. I’m not saying to leave auto-save like this - just to try it out for a little while to see if it makes any difference. You could also just hit cmd-S and see if you get a spinning beach ball for a while.

Thanks and all the best,
Keith