Exporting to plain text with two line breaks between paras

This has got to be a basic FAQ, but I’m a little frustrated by the search (searching for +plain +text +export tells me those words are too common to be used as search terms.)

I’ve been using Scrivener to compose text that ends up pasted into forms on web pages as plain text.

By default Scrivener display paragraphs with an extra space in between them. When I export that to plain text, it puts a single line break between the paragraphs:

para1 para2

What I want is two line breaks between the paragraphs:



Is there any way to have Scrivener do this without having to hit ‘enter’ an extra time’ after each paragraph as I type?

You can use the search and replace tool to fix your existing paragraphs. Just hold down the Option key and press return in the Find field, and then do the same thing twice in the Replace field. I recommend turning off the psuedo-paragraph spacing in the text editing defaults for anyone working with plain text. It can just get too confusing when the editor is putting in indents and phantom spaces that aren’t actually there.

There is going to be an option in the Compile Draft settings for this for the next free update - to insert an extra line break between paragraphs that have double line spacing between them. This has come up as an issue when exporting scripts. There’s no way to do it yet, and I have yet to implement the code for this so there’s no actual time scale, but it should be part of the next official update (hopefully late Spring/early Summer - uh, in the UK, that is).

Where is that preference, Amber? I can’t find anything called “Turn off psuedo-paragraph spacing” in Preferences|Text Editing or in the Compile Drafts set up. What should I look for?


What I meant was, in the Text Editing preferences, there is an area at the top (General Text Attributes) where you can specify the default paragraph settings. This includes things like tab stops, margins, line spacing, paragraph spacing, and indent. You’ll find all of the controls are identical to applications like TextEdit; it is the standard Apple ruler. To remove indent, make sure both margin sets (the down-arrow and the horizontal bar) are aligned on the left. To remove paragraph pseudo-spacing, set the “Spacing” drop-down to Single, or use the “Other…” option for more fine-grained control. I like a little line spacing for legibility, but no paragraph spacing.