External sync hanging again

I am trying to external sync my project with a brand new folder and it keeps hanging on the 10th file. I’ve recreated that file… it just has bold for names, and regular for the rest. it’s a times new roman font. before I had to copy and start a whole new project to get this to work-- but I really do not want to do this again…
is there some way in the console log to see what’s going on?

Synching with the recommended Dropbox, or something else?

First tried dropbox for an external folder, then tried iCloud. neither work. it’s stopping at the same file, even when I recreated the file and moved it one down.

I recommend you forget out iCloud. But why it stops … have to think. Others may have thoughts.

I tried again, and it went further and stopped at 137. gotta be a formatting problem somewhere

got these two errors
The file failed to write to disk. Please check your permissions, disk space, and that the document name does not contain characters that might generate an invalid file.

What’s the name of the 10th file?

the 10th file was simply INTRODUCTION

the new one is a quote as are all the others
none of it makes sense.

What format do you use? Plaintext, RTF, FDX or Fountain?

ok, this gets weirder. so the 2nd file it decided it didn’t like was file 136. I recreated it and all that, didn’t work. unbolded all the formatting and resynced—still got error message which says blah blah file 137 out of 600 … however, I have only selected manuscript docs and there are actually only 137 files. so the entire book IS synced but I am still getting an error message.

I need the RTF …
trying to keep the formatting

Okay, that’s really weird… Is it possible that documents (Research, etc.) other than draft documents are also synced? (Another checkbox in the sync setup dialog, likely “off” by default.)

I don’t know much about cloud sync,
but if I wanted to diagnose where the problem comes from, the first thing I would do would be to sync my project with a folder that isn’t linked to the cloud.
Then, in a second step if all went well, I’d then drop that sync folder in the cloud sync folder.

If it fails at step 1 : issue is with Scrivener.
If it fails at step 2 : issue is with cloud sync.

And last if it doesn’t fail at all: issue is with the combo Scrivener-Cloud (The cloud service perhaps impeaching Scrivener as it tries to write/rewrite HIS files.)

1 Like

And also (now that I think of it), I remember having an issue in the past when exporting RTF files…
Perhaps sync and export behave alike enough so that you encountered the same issue.
(Although I run the Windows version. But might be worth the verification – who knows?)

Do you have documents which title contains “/” ?

On my end, Windows version, whenever I had “/” in a title, the file ended up splitted:
“Mary screams / Joe runs away” ending up as two separate files.
And “Joe runs away” being impossible to recover. (Windows’ file explorer showing it to me, but saying it didn’t exist at the same time.)

yah it’s very weird. I don’t have any / docs but I do have lots of “” quotes.
anyway, it seems to have worked!

May I ask what exactly did ?
The whole thing ?
By what steps did you make it work ?

if you scroll up–that’s what worked, my last reply

I’ll suppose you meant removing the quotes…
Well, that is wonderful. Mysterious… but yet wonderful.

If that is the case - if all you had to do was to remove the quotes from your documents’ titles -, it then goes along the lines of special characters not being so much welcomed in files’ name. (And Scrivener not filtering them out.)

I can say that, personally, ever since that day where I had to waste hours trying to figure out how to clean there-but-not-there files from my system, I avoid them as the plague in my documents’ titles.

As Scrivener’s document titles become file names of some sort, best to avoid any “special” characters that a file system (macOS, iOS, or Dropbox) may not prefer. macOS can handle a lot of “special” characters. Dropbox’s has more limitations as they are not running macOS on their servers.

See Naming Dropbox files and folders | Dropbox Help

If one has synching issues, a good place to start looking is for these sort of characters.

1 Like