Facebook window opens every time I open a website link

I am a very new user so not sure if this has come up before, but each time I open a web site I have saved in my research folder not only does it open in the Editor window, but a random facebook page opens in my browser (Google Chrome).

facebook.com/tr/

It is a completely black page with nothing else in it.

Annoying and definitely breaks the flow of concentration.

I visited that link using a quarantined browser and had a look at the code for the page. It appears to be a simple invisible single-pixel image—commonly used to track your browsing behaviour from one site to the next. I don’t know why it is loading an external page rather than just tracking you silently as it was surely intended to be doing.

Whatever the case it’s a problem with the page your archived. If you don’t need to site content archived in its original form, it might be worthwhile to use the Documents/Convert/Web Page to Text command on these research pages. That will strip out all of the active HTML. You can then clean them up and have them stored as normal text.

I am noticing this behavior too and have one suggestion to help this issue. I am converting these websites to text to stop this from happening and cut down on the need to load a web page, but is there anyway to preserve the web address at the bottom like is done before converting to text? I use the web address as a reference in my main document.

Thanks
Screen Shot 2018-04-20 at 10.03.52 AM.png

Unfortunately not at the moment. It is a blind spot that I noticed as well. I typically import web pages as text from the very start, with the preferences set to do so in the Sharing: Import preference pane. With that setting when you import a page as text Scrivener will insert a Bookmark leading back to the original page for you—a thing I take for granted. But that bookmark is not added when importing as WebArchive, and not created when converting from WebArchive to text.

It would seem to me a better approach would be to save a Bookmark for all Web imports, or if failing that, at least generating one when converting.

In the meanwhile that is what you’d just need to do manually for the moment. Visit the link, in the browser hit ⌘L to focus the address bar, ⌘C to copy, click into Scrivener’s Bookmark pane in the inspector, and ⌘V to paste the URL as a Bookmark, then convert.

Amber
Thanks for the reply, but can you clarify just a bit more about what you are describing and how to set it up? I have this setting as such:

Yet, when I go to Research --> Add --> Web page and paste in the URL, it creates a note in research, but where exactly is the bookmark? I have opened the bookmarks pane, but do not see it listed there.

Thanks

Your settings are good. Make sure that you have switched the Bookmarks pane to “Document Bookmarks” vs “Project Bookmarks”. Each document in the binder can have its own bookmark list, and and that is where the URL should be added, not the global list.

AmberV
Thanks for the reply. Although, I will admit, I am not exactly sure what you mean. I have this:

is this the “document view”?

Sorry, still trying to figure out all the nuts and bolts of Scrivener. :slight_smile:

To clarify, I’m referring to the Bookmarks tab in the Inspector of the main project window, not the Project Bookmarks sidebar as viewed in a QuickReference panel.

As an aside, it might be you are well aware of the distinction, but up until now we’ve been talking about web pages being imported into the project—either was WebArchives (with the undesirable Facebook tracker coming up) or as converted to text. What you have in your screenshot here however is a series of URLs you’ve stored as project bookmarks. These are not imported into the project—they are links to websites and nothing more than that.

For the sake of trivia, if you were viewing the text of an imported webpage in this Quick Reference panel (select it in the binder and hit the spacebar), then you would see a dropdown in the top right corner of the window labelled “Editor Only” by default. Click that, and from there you could view its Document Bookmarks list—which would include the “Original URL” bookmark you’re looking for.

Like I say though, this is also accessible from the Inspector, and there and only there can you flip between project and document bookmarks in the list.

See also…

  • §10.3, Project and Document Bookmarks, pg. 227.
  • §12.6, Quick Reference, pg. 300.
  • §13.4, Inspector Bookmarks Tab, pg. 318.

This just started happening tonight, and I’ve been using Scrivener for several months now. I’m really disappointed because I liked being able to open a webpage, split the screen with the document I’m typing, and not have to worry about this Facebook thing every time. I just want to know how this happened (if anyone knows) and whether I go back to the way things used to work, without having to resort to a new work-around.

So annoyed.

I don’t think there is a way to save a WebArchive file in a cleaned state. Otherwise I would suggest using a few good privacy extensions in Safari, saving the WebArchive from there, then importing that file into Scrivener. But in my testing, if I install something like uBlock Origin into Safari, so that junk trackers and ad services like scorecardresearch.com, facebook.com, doubleclick.net and so forth are blocked, then save a .webarchive and drop that into Scrivener, I get all of those connection attempts logged in my blocker anyway. A messy page like CNET tries to connect to nearly twenty different servers when viewing what is, in theory, supposed to be an offline archive!

Since this problem only showed up recently, my guess it is a recent 10.13 bug. Hopefully Apple gets it sorted out.

Has anyone got a web archive file they could attach to this thread that shows the problem? (You can just export it from a Scrivener project, zip it up and attach it to your reply using the “Attachments” tab below the forum reply text entry area.)