file apparently corrupted -- what to do?

I had continual problem with one Scrivener project, but not with the others. I got this error message:

so I copied the text to another Scrivener file. it worked okay for a while (possibly). now I have had the same problem with no file. any idea what happened or what I can do about it?

Having the exact same problem running OS X 10.6.8.

It began immediately after I downloaded version 2.3.1.

fairly certain that this happened before I DL’ed 2.3.1.

Just to clarify, I am having this problem with all my Scrivener files and the program gives me this message as soon as I type or hit any button, then closes immediately.

so, I think that things went all right with this file, then when I opened the film again and had the same problem. I don’t remember, if anything, what I did to work around it before. anyway, still broken in exactly the same way.

bump! still having trouble and getting the same error message on closing. sometimes Scrivener will allow me to close without trouble. the longer I keep it open and the more I edit it, the more chance of trouble. I get the same error message:

I also had the following error message when trying to delete certain files:

I have, again, copied all the old data into a new Scrivener file with a new name and, again, still had the problems re-occur. (well, the first one. I don’t have the files I wanted to delete because I made sure that I did not transfer them.)