"File" behaves like "Folder"?

This item in the binder is a “File” / document but it seems to behave like a “Folder” as it shows the items it contains (dotted lines):

Why is it like this and how could I turn it into a document?

Folders and Files only differ in the icons. Otherwise they are the same.

What is the undesirable behavior you’re seeing? Everything looks correct to me.

Oops, I always thought a folder shows the content of the items they contain and files don’t. It really is and was not like that? So why are there folders and files at all if they differ in its icons only?

That a file (other than a folder does) shows the content of the items it contains.

In Scrivener, that’s not the difference. Primarily, you use folders to distinguish how they come out during the compile process vs. how text files come out.

For instance, a novel with chapter folders and text documents would typically be compiled so that it ignores any text associated with the folder itself, and only uses the folder to signal when a new chapter is starting, optionally including the title of the folder in the chapter title. Files would typically be “scene” documents, and compile wouldn’t usually include their titles; it would also only separate adjacent file contents (the text) with some kind of separator, like 3 centered hash-marks.

There are some things that folders do within Scrivener differently than files; like the default way that they display in the editor if you click on one (click on a folder, get the cork board, click on a file, get its text contents… that kind of thing).

If you dont’ want the files indented under your other file to show in the binder, click on the arrow to the left of your file, and they’ll collapse up into it, just like they do for folders.

Alright, I understand, thank you very much for the very understandable explanation.

What you are describing is the default behaviour yes, and one of the notable UI differences between folders and file groups. However it is possible to make file groups act just like folders in every way, including whether they load using a group view mode instead of single-text. So maybe you have changed this setting and forgot about it?

It is Treat all documents with children as folders, in the Navigation settings tab.

Ah yes, that is it! Yes, absolutely forgot about it respectively wasn’t aware of the consequences obviously, sorry.

When I just deactivated that option all open Scrivener projects crashed but now it works again. Great!

And even the invisible text is visible again.

Many thanks.