File is not writeable: Access is denied

Next is says ; Auto-saves need write permission to your project.

Situation: hard drive crashed. Got new one. Moving my project over to my own new user file from the computer companies back-up file that is sitting on the C drive as well. I copy to my new folder, paste, etc and it won’t let me alter/write to the files. I changed permissions somewhere, but then it immediately told me it couldn’t auto-save and then wanted to do a back up.

I’m already the administrator on the computer. How do I make the entire project writable? The copy in the back up folder lets me write/change things fine. It’s just the copied stuff that is giving me the problem.

I hope I have described this well enough to adequately lay out my problem.

Frustrating, now my drive, and now I can’t get to my book!

It’s probably something incredibly simple . . .

Take a look at MimeticMouton’s answer in this thread…
https://forum.literatureandlatte.com/t/error-message-when-try-to-open-file/22999/1

If that doesn’t do the trick, do a search on the forums, via search field in upper right corner of web page, on “need write permission” and review the threads that the search turns up.

Other possibilities… the autosave location it is trying to use may not exist… and perhaps let it/tell it to do a backup to somewhere you can access on your new hard drive (not using compress/zip option) and then use that backup copy as your starting point.

Hope that helps.

Post back as to how it goes.

I’m the only user and am the administrator, but the program is not acknowledging that. I right clicked and changed the read only, it made me say OK as the administrator on two different input boxes but now won’t even let me open the project. This is when cut/past. It won’t even cut/copy. Cut/copy - nothing shows up in the new folder. Nothing.

I think I am going to turn the computer off and start again.

Thanks for the info. I’ll just keep trudging along and making searches for this topic. I’ll post when I find an answer. Any other ideas will be much appreciated.

Now the message reads - "Cannot access:‘C:/Users/mrtla_000/Doccuments/Hanging by a thread.scriv/project.scrivx’ File is not writeable:Access is denied. Auto-saves need write permission to your project.

I changed the property on the folder to turn of read only. I also went to security and changed the setting so everyone had permission to do anything.

There has to be something really obvious that I am missing. The copy that I made to my Passport external drive works. I just can’t get the copy I made from the Geek squads file to work on my primary solid state hard drive!

Grrrrrrrr.

I’m going to delete it and start over. Not expecting different results. Hoping someone is going to go ‘doh’ and give me the easy answer.

To the extent that I used to sort of understand this stuff, I’m getting rusty…


Simplistic gross fix/workaround to try… If the copy of the project on your external Passport drive works, what about copying it back onto your SSD? Perhaps to a slightly different location or name… or perhaps first delete the problematic version on your SSD before copying the working version onto it.


More technical possible fix… I could be really really wrong and mess you up… DANGER WILL ROBINSON!!! USE AT YOUR OWN RISK!!!

A possibility… When you copied or restored the project from the Geek Squad media or file, was that via a regular drag or copy/paste… or some sort of backup/restore utility? If was via a utility, there might have been an option in there somewhere to tell it not to recover files with their original security settings. That can have a bearing as, even if the visible user name you use with the original (now replaced) drive and the new drive are the same to the eye, there is an underlying unique hashed “SID” number that Windows actually pays attention to… and it will have been different on the original drive and the replacement drive (as you are presumably running under a new/different install of Windows than before). So, one possibility might be to repeat the restore, telling it not to bring over the original security.

Another possibility… When you changed the properties, etc. on the project .scriv folder, did you explicitly tell it to apply the changes to everything in the folder? I’m wondering if the changes were only applied to the folder itself, but not to its contents. I’m on Windows 8.1, so the following may vary a bit depending on what version of Windows you are…

  • Right click on the .scriv folder and select Properties.
  • Click the Security tab
  • Select the group or user name you selected before
  • Verify the permissions listed for it are as needed
  • Click the Advanced button at the bottom
  • Click (put checkmark in checkbox) "Replace all child object permission entries with inheritable permission entries from this object
  • Click Apply
  • While still on this screen, there’s also the option of changing the owner. Don’t know if that would help or not. If you do, you’ll type your username, not your SID, into the dialog/prompt asking who to change the owner to. If you do, repeat the “replace all” process above again.
  • Click OK

Hope that helps. This is probably old hat and covered much better somewhere in the forums relative to Scrivener in restore situations and elsewhere on the Internet relative to restore situations in general… but I’m not finding a really good example to point you to. For a sampling, fire up your favorite search engine and do a search on something like “restored files read only”.

Very Helpful! I right clicked the folder. Clicked properties. Clicked securities and then made all users have permission to do everything (read, write, etc.) Now I can use the copy on my C drive. I hope I didn’t inadvertently screw myself by letting anyone have permission to do anything, but we’ll see and i’ll be backing the living sh** out of the project.

I’m hacking out my first book as well. Got my working title and everything. My editor is on my ass and he has a couple people who’ve read parts and have expressed interest in taking it to the next step.

So . . . . I better actually figure out the details and the order of my story line, eh?