File Lost

I made a somewhat large - perhaps 50 nodes, scrapple doc. I added 2 images via drag and drop. All worked fine. I periodically save my work. I screenshot my work as well for revision management. I rebooted my mac and the original source file .scap was gone. Entirely. not on icloud not on local machine.

Looks like I’ll need to recreate the entire doc from the screen shot.

Would reccomend an auto-version control save-as feature. Also, I’m not sure if scrapple was running when I rebooted. I find most apps manage to either stop the reboot process or save the work.

Have you tried using Spotlight to search for “.scap” files? Another thing to check for, if the file actually never was saved, it might still be in the ~/Library/Autosave Information folder.

As for automatic save-as, you generally don’t need “save as” with Mac software that supports the modern document editing system (indeed I think the command is still removed from the obvious UI in the File menu, you have to hold down Option to see it?). You can tell if a program is compliant by going into the File menu and looking for a “Revert To” submenu. If you go into the version browser, you should find every single save gets logged and you can flip through them rapidly with a chronological control on the right. So like I say, the old notion of littering your drive with dozens of “save as” copies is largely unnecessary.

As for what should happen when you reboot, whether software saves documents on close or asks you to save is determined by the Ask to keep changes when closing documents setting, in System Preferences: General. I can’t speak for what most software should be doing on your system specifically, though, that depends on what you have installed.

Thanks for the pointer to the option to prompt for saving files in the systems preferences general settings;
I’ve done that now.

I did try to use spotlight to find scap type files. I also used the command line 'find -name ’ … command to look for the lost file. No joy.

Revert to shows up, but my file isn’t anywhere to be found, so no revisions are available. Thanks for pointing out the revision history. I can see it on files that still exist here. And option does show the save-as option.

a revision control system makes sense at this point. I can set it up manually.

Hmm, and nothing in the autosave folder? That’s baffling, but if even find on the command-line can’t find it, that narrows down potential places to external drives that were plugged in and didn’t remount and that kind of stuff. You could also widen the search to the root / level to see if it got saved somewhere odd. That will take an awful long time to run, but it’ll go anywhere you have permission to look (and thus anywhere you could save). There is also Time Machine, if you use it. You’d need to have some idea of where you saved it for that to be effective, and again I’d check that autosave folder—but if you worked on it for at least an hour it should be there.

As an aside, in your shoes, if I lost a file after a reboot I’d be doing some immediate full disk backups and disk first-aid troubleshooting. That’s not something that should happen!