File Not Compiling


I have a file that isn’t compiling anymore. It’s about a year old and I have successfully compiled to .mobi many times in the past, but today I updated my back matter and it’s not completing the compilation. The compiling screen shows the progress bar, but when it reaches the end it won’t go away and the file isn’t in my hard drive. I’ve tried to compile in different formats, but it isn’t working either :cry:

What can I do?

I found out more.

Turns out it won’t compile if I select the Front Matter. It only compiles if I unselect Front and Back matter… It’s happening with all my files.

Any suggestions?

It’s the special characters in the front matter. How can I override this?

What are the special characters? Why do you need them?




and the rest that take from metadata.

If the page with these characters and is selected during compile… it won’t compile.

I changed the settings to show all internal errors and it is showing an error:

NSRange Exception
Reason: NSMutableRLEArray objectAtIndex:effectiveRange:: Out of Bounds.

It lets me send the error to Scrivener and I have.

If this is happening to someone else, please let me know what you found.

Thank you.

Ok, those aren’t special characters, they are placeholders, and they should work fine.

If you strip the project down to just the front matter and a file or two, does it still fail? If so, please ZIP the project up and send it to our support address. Put my name in the subject line to call it to my attention.


I did what you asked and it still crashes.

I will send the file.

Thank you