File won't open

I tried to open a file that was last open on 12 januari 2017, but it did not opened. This was what popped-up:

‘‘The project at “/Volumes/My passport/Bestanden/Schrijven/Verhalen/Bloed voor Bloed.scriv” seems to be of an older format, but no binder.scrivproj file could be found inside it. It may be missing or corrupt, possibly because of a problem with the device on which it is stored, or because of a synchronisation problem.
Try ctrl-clicking on the project in the Finder and selecting “Show Package Contents”, then look for a file entitled ‘binder.scrivproj’. Ensure it has not been renamed by a backup routine. If it does not exist, try restoring from a backup.’’
But my computer sas that the file is ‘‘empty’’ (while there should be a complete manuscript)

Pleas, pleas help me. I really want this file to open again.

MyPassport? Is that an external HD accessed through WiFi?

No it is a external hard drive, where I keep all my backups.

Do you connect the external drive with USB or thunderbolt?

Did you do as instructed, i.e. right-click to get the popup menu and then Show package content?

I connect it whit USB, and yes I tried all the instructions. But I can not see the hole option; ‘show package content’

Oh and thanks that you both are trying to help me! :smiley:

From the message you got it sounds as if the project was saved from Mac Scrivener version 1 and that you tried to open it with version 3.
Are you sure that it is a version 2 project?

Can you give us a screenshot of the project .scriv icon as you see it in the finder, especially if you do a right/ctrl-click on the icon. If you’ve never done it, Shift-Cmd-4 gives you cross hairs which you can drag across the appropriate area to save having to make a shot of the full screen. It would help us to know exactly what you are seeing.

:slight_smile:

Mark

Hey, sorry for my late reply, I could sent screenshots but I live in the Netherlands so unless you can read Dutch it would not help that much. But the document icon is a older I con whit the scrivener logo, when I follow the steps that the error message gives me I open a window whit information.
It sas that it is 0 kb, was made at 1 July 1016, was last open on 12 January 2017.
That it is a scrivener project and the location of the document.
There is not more that I can find. No: restore form back up or anything. So the strange thing I found that this document is completely empty, otherwise it woud be more then 0 bytes.
Anyone ideas?

I think you missunderstand Xiamenese’s request for a screenshot. It’s not the error message or the file info we would like to see but screenshots from Finder. 1) the icon itself and 2) the contents of the project package.

Your ‘Bloed voor Bloed.scriv’ project is not a file. It’s a package, which means that it is actually a folder. If you hold down ctrl when you click on the project in Finder you get a drop down context menu looking like this:

If you then click on Show Package Contents, Finder will open the folder and show you what is inside.

If there is nothing inside, the next question would be - how did you save or copy it to the external hard drive?

When I ctrl + click on the icon I don’t get the hole ‘Show Package Contents’ option. That is part of the problem.

How did you put it on the external drive?

I copied it from my laptop, but I had to remove all my files on my laptop because of some problems. So it is the only file I have.

I hope you have some kind of backup, like Time Machine.

How did you copy it? It seems that you managed to copy the folder without it’s content, which shouldn’t be possible.

You still haven’t shown what it all loks like in Finder.

Does this help?


As you can see, that file has .scriv appended to the file name but others haven’t. In Finder Preferences -> Advanced, you can turn on file types so you can see more clearly what kind of file it is. I am not sure that the Bloed voor Bloed really is a Scrivener project.
You didn’t answer how the file was put on the external drive. Copy? Save from inside Scrivener. How? Using a Mac or a PC?

So when I look at the file types, it is a .scriv just like my other scrivener projects.
Originally I wrote it on my laptop (mac) and then I copied it on my hard drive. (like I did whit all my projects to make a back up)

Well, you must have done something else because Scrivener only reads and writes the various individual files that make up the documents in your Binder. By the look of it you managed to copy the project folder but it ended up like a file, and a file can’t contain all the files and subfolders of a Scrivener project.

What you have seems to be an empty file with the ending .scriv instead of a package containing the project. And this is not something Scrivener can do.