Find and Replace Bug?

I’m really not sure if this is a bug or not. I opened an older project last night and saw that some double quotes were represented by paired single quotes. In this case it’s almost all closing quotes, so they are simply two apostrophes/single quotes together.

When I tried to run find and replace on the single quotes to turn them into proper typographic double quotes, the find command didn’t recognize them at all – it told me there were none. Even cutting pasting them into the find box didn’t help. The transformation command just made them into smart single quotes.

Is this a known problem, or am I doing something wrong?

Smart Qotes are anything but. I have tried all methods suggested on this forum or indeed by the developers themselves and nothing works if you are on a MAC. Simple solution follows: Select all annoying text and COPY (cmd+C). Open WORD and paste offending text into a new doc file( cmd+V). Use WORD ‘replace’ facility to find all straight quotes. Replace with a curly quote from the keyboard while in WORD using ‘replace all’ button. Once all replaced, cmd+A to select all the text, then cmd+C to copy. Go back to Scrivener and the offending text. Go back to bottom of your screen and press ENTER twice to drop your cursor below the existing text and press cmd+V to paste your perfected text below the existing. (This is so you don’t overwrite your existing text with possible errors. Once satisfied with result, select all original text and delete. Please note! Any text you add to this will still put straight quotes in. Do the same again to rectify.
Bill (Urban Tiger Radio Podcasts)

What happens on a Mac has no relevance to the Windows Beta … they are completely separate developments.



This has been improved a lot (including searching/replacing Line Feed and Carriage Returns) and the changes can be tested in the next RC8 update.