Find does not work

The Find command defaults to the Find and Replace command, and there is no function that simply finds a word or phrase and stops there or high lights the word(s). The Find and Replace only finds and replaces all. The Find Next does nothing as far as I can tell.

Otherwise, I am enjoying using Scrivener. Thank you.

Marilyn Holt

I downloaded the newest version Beta (1129554) 64-bit - 04 Dec 2020 and there is no change. This is a major problem. If you need screen captures or more detailed information, I can provide that.
Thank you,

To enable the find buttons you must have an active editor, as Find searches in main editors, copyholders, inspector notes, etc. Click within the editor you want to search in and return to the Find dialog. This should enable the find controls and functionality.

If this does not help, please upload a screencast. Find works fine in my tests.

Works fine for me. Pressed Control+F, yes the dialogue is a fine and replace dialogue, but if you just type your search word and press next, it finds the next word on the page.

This is standard Windows behavior, but I agree, it is not optimal. The find dialogue box allows for either find or find and replace depending on whether you put something in the replace box. Again, this is standard. Don’t worry. It will not do what you would expect which is replace with nothing, which is in the replace field. After 5 or 10 years, it will become less disconcerting.

I have never run into this in Windows, so I do no see it as being usual. Here is my problem, again. The find/search function is messed up, and has been since mid-summer. It only opens with the find and replace function, and it does not let pause while it is replacing. I have reported this for each of the version sent out. Is this going to be fixed?
I am using Version: Beta (1129554) 64-bit - 04 Dec 2020

Find, find all, replace and the associated functions worked in the W-1 version and in earlier version of W-3. I know because I used it.

If you click Next, it’s nothing but Find. If you do that and click Replace & Find, it does that. I don’t see a problem.

If you click Replace when the second box is empty, it WILL replace with nothing, as I’d expect.

Here’s a video of my testing.

Find worked as advertise at THIS machine at least (Win10 running under Parallels on a Mac).

Odd behavior at the end was not odd at all, it turns out. It occurred because I’d managed to change “advanced” → “advancedTest” twice for that instance, so the result was “advancedTestTest”. Reversing the change once got me back to “advancedTest”, removing only one of the “Test” substrings.

Your video was great. I hadn’t even bothered to look at exactly what Scrivener did. Just responded with find and replace often combined in Windows and not being a problem.