'Find' issues after 2.4 update

My apologies if this has already been posted. I can’t figure out how to do an exact phrase search in this forum. If I search on “2.4 update” I get over 7000 hits. Nobody’s got that kind of time! :stuck_out_tongue:

On to the issue:

After upgrading to 2.4 today, I have a problem with ‘find’. Usually with find, when you do Apple-F, any text within the find text box is highlighted ready for you to type over. This no longer happens. Which means, if you’re doing multiple finds for different words, one after the other, you have to Apple-F and then mouse to click in the find box (or tab). Very frustrating when I’m using find all the time during editing.

Is there a reason for the change?



Hi Gilly,

I can’t reproduce this, I’m afraid. The text boxes have changed so that they can show invisible characters now, so is possible that something odd has crept in, but when I hit cmd-F, the text in the “Find” box is always selected. Can you please post steps to reproduce the issue?

Thanks and all the best,

Hi Keith,

Here are the steps:

  1. I’m in document mode, page view. cmd-F to find. The Find box is initially empty.
  2. Type in for example Casino, and it’s found no problem.
  3. Leave Find box open, click back inside document to continue editing.
  4. Try a subsequent cmd-F for a new find. Casino is highlighted in grey. Any attempt to type anything will give an error sound.

The workarounds are:

  1. Close the Find box after every find.
  2. Either Tab or double-click ‘Casino’ with the mouse to highlight it in blue and be able to type in a new word.

The other issue (and I’m sure this didn’t happen before) is when you’re doing multiple finds, and you cmd-tab away from the document (say to check mail), then go back to your multiple cmd-f exercise, and it stops working.

  1. cmd-F, type in Casino, hit return.
  2. ‘Casino’ is highlighted in grey in your document when its found.
  3. Tab to highlight Casino and change it to Camera, hit return. This works no problem.
  4. cmd-tab away from Scrivener to another application, then cmd-tab back again.
  5. Tab to highlight Camera, and change it to Cruise, hit return.
  6. Nothing will happen. Cruise will turn grey in the find box. Camera will remain highlighted in grey in your document, and you’ll get an error sound on return. It’s as though Cruise is now being searched for within the word Camera that’s selected.

The workaround is:

  1. Click back in your document, then click again to deselect Camera.
  2. cmd-F, return.

I’m sure these things didn’t happen in the previous version? I’m editing and doing a lot of finds right now. It’s driving me a bit nuts!

Thanks Keith. If you need anything else, just let me know.


Hi Gilly,

It sounds to me as though something odd is going on with your window server, whereby windows aren’t becoming active as they should. For instance:

Not for me - the Find box appears, is made active, and “Casino” is highlighted in blue. Typing overwrites it. From your description, it sounds as though the Find panel has been brought to the front but not made the key (active) window.

This time, it sounds as though the main project window has been brought to the front but not made active.

In both cases, Scrivener just calls Cocoa’s -makeKeyWindow method, which passes it onto OS X’s window server to bring the windows to the front and make them active as necessary. None of this has changed between versions. The only thing that has changed between versions is the text boxes themselves, but that has nothing to do with whether the window is made active or not. So it sounds as though something is interfering for you. Do you have any window management software installed at all? What happens when you try the same things in, for instance, TextEdit?

All the best,

Tested in Text Edit and it works fine.

I used to work in I.T. support and hated hearing this line, but I’ve got to say it … I haven’t changed anything. :smiley:

I use Witch by Many Tricks to alt-tab between application windows (rather than between applications), but no window management software installed. And I’ve been using Witch longer than I’ve used Scrivener.

The only thing that has altered on my system is the Scriver update. Do you want me to go back to the previous version as a quick test?


Before doing that, I would try the following:

  1. Delete com.literatureandlatte.scrivener2.plist from the ~/Library/Preferences folder (let me know if you don’t know how to find the now-hidden ~/Library folder).

  2. Trash Scrivener and re-download and re-install it, just in case it is a corrupt interface file in your download.

If that makes no difference, then yes, please test 2.3.1 again. Also, are you on the 10.6+ version?

Thanks and all the best,

LOLZ, now I’m going to regret saying “honest, I didn’t change anything”!!

Firstly, yes, I’m running the 10.6+ version on OS 10.7.5.

Of course, a reinstall would solve the problem because it blows away one of the things you helped me with before … which is how to stop the Find window closing after you hit return. So of course it works on a fresh install because without that in place, the Find window always closes. Mine doesn’t because I’ve run:

defaults write com.literatureandlatte.scrivener2 SCRSuppressFindPanelAutoClose YES

So these problems only start after I suppress the find window.


Ah! Okay, I see what you mean now. This is indeed down to the new text fields, which are really text views pretending to be fields - I’m fixing it now.

All the best,


Completely forgot I’d implemented that! If you hadn’t suggested the reinstall I might never have remembered!!

Thanks Keith.


Hi Keith,

Installed the new update which partially solved the problem. The Find window is now becoming the active window and I no longer have to Tab to highlight the Find field and overwrite any previous find.

However, it still gives a problem when I alt-Tab to another window and come back again. The Find window is highlighted and I can still overtype, but it still seems to search in the previously highlighted found text and not find the new entry.

Let me know if you want detailed steps/screenshots.


I managed to reproduce this once, but this isn’t specific to the 2.4 update - it’s just not finding the text to find in. If you can find steps that always reproduce this, then please include them, yes, and I’ll take a look at it when I get time for 2.5.

All the best,

Hi Keith,

It’s not a priority, because I can work around it by clicking inside the document and deselecting the previous highlighted find. It’s just annoying.

I can reproduce it every time:

  1. Run defaults write com.literatureandlatte.scrivener2 SCRSuppressFindPanelAutoClose YES

  2. From your document, cmd-F, enter find text (crumbs in this example), it will find and highlight the found text no problem. Leave Find window open and found text still highlighted (see crumbs.png).

  3. cmd-Tab away from Scrivener to a different app and cmd-Tab back again.

  4. With Find window still active and found text still highlighted, overwrite the found text with a new word, and enter (leader in this example).

  5. The previously found word ‘crumbs’ is still highlighted in the document. The new search ‘leader’ is highlighted when you press enter. And the find fails (see leader.png)

  6. This ONLY happens if you cmd-Tab away and go back in again. If you stay within Scrivener you can do multiple finds to your heart’s content.

Let me know if I can help with the fix in any way.

p.s. Tip of the hat to John Steinbeck for the awesomeness that is this Grapes of Wrath quote :mrgreen: