Finding filenames for Scrivener Links

I am new to Scrivener (Mac user) and need help understanding the use of “Convert Scrivener links to HTML links” in Compile settings for my ebook. I plan to use a good number of images and PDFs that I’ve uploaded to the Research area. I see the images in the editor on my pages, but they aren’t compiling in my ebook.

According to a post I found on this subject, it instructs us to “Edit>Add Link” rather than use “Add Scrivener Link.” If this is true, that I should not be inserting them as a Scrivener Link, am I pasting a “File” since it’s in my Research folder? How do I locate the filenames for each of those that I want to link?

Is there any chance that Scrivener would add that feature that turns each Scrivener link into HTML when compiled as an ebook?

Thank you so much!
Karen

Hi Karen,

Scrivener links are already converted to HTML links when that option is ticked. However, it will only convert to HTML links those Scrivener links that point to files included in the compiled document. In your case, you seem to be trying to create links to files in the Research folder, which are not included in the compiled document (given that only the Draft folder is compiled). So, there is no point in Scrivener creating HTML links for those documents because there is nothing for Scrivener to link to.

You won’t be able to include PDFs in e-books anyway, but for the images, what you should do is paste them into a text file that is included in the Draft, and link to the text file instead of to the file in Research.

All the best,
Keith

Keith, thank you – that makes sense, now that you have explained it.

However, the one snag I’m not figuring out is how to leave out that DRAFT folder (I’ve named it Scrivener Links) from my TOC.

I have unticked that folder in CONTENTS in the “Include” column, and tried “Compile: Included Documents” – resulting in no Scrivener link working (I do have the “Convert Scrivener links to HTML” ticked), so then I tried “Compile: All” in the hopes that it would NOT include in TOC (it doesn’t), but then the text is not hyperlinked.

(I’m compiling for Kindle ebook.)

Thanks! If I can resolve this part, then you will have helped me jump a huge hurdle in getting all of my presets figured out – I am deeply grateful!

I’m not quite following you, I’m sorry to say. The “Draft” folder shouldn’t have any “Include in Compile” option and it is not possible to include the folder itself in the Compile - only its contents get included. Just to be sure that we are talking about the same thing, the “Draft” folder - which can indeed be renamed - sits at the top-level of (leftmost in) the binder, and has the little manuscript title page icon (it is renamed “Manuscript” in some of the novel templates).

The automatically-generated table of contents will include any documents that have a page break between them. You can instead create your own table of contents with only the links you want included, though. To do that, you create a document in the Draft (or in the front matter folder) and add all the Scrivener links you want in the contents, formatting it as you want the contents page to appear, and you make sure that the title of the document matches the title of the contents page given in the “Layout” pane of Compile (“Contents” by default).

All the best,
Keith

Thank you, Keith – sorry I didn’t specify that I was describing the options in the COMPILE dialogue screens, not in the Draft folder area. But I’m glad I know now that the TOC is automatic, unless I turn it off and create my own – which I’ve just done.

Do you mind answering just 2 questions, now that I’ve compiled it after creating my own TOC?

  1. I’m attaching a screen shot of the LAYOUTS box in Compile. LAYOUT view in Compile for Kindle ebook.png Even though the box is ticked to begin the book after the Front Matter (which is where my Contents lie), it’s counting Contents as my 1st chapter. How would I correct this?

  2. The screen shot attached of the CONTENTS box

    in Compile shows where I’ve placed one of the images that I want as a Scrivener link (in the screen shot, it’s called “DecisionMAG” under the Bible Professors folder):

And the link works fine in the Jensen document, now that the Scrivener link is pasted into a text file in the Drafts area, rather than the Research. However, it’s showing up as a page right after the one before it (the Jensen page where it’s referenced). I don’t want it to show up as a page, but hidden & referenced only when someone clicks on the Scrivener link in the Jensen page.

I must be missing something obvious here – sorry that I just cannot see it . . .

Thanks so much for your patience!

When you say that it’s counting it as your first chapter, do you mean that it’s adding “Chapter One” to the start of it? If so, there are different ways to address this:

  1. You can tick “As-Is” for your contents document.

  2. You can set the “Contents” document not have the title prefix and suffix added in the “Title Adjustments” pane.

  3. You can adjust the section layout options for the contents document level and type in “Formatting” (I note you are currently using a folder with some text in it - you might want to use a text document for it so that you can change the formatting of level 1 text documents in “Formatting”. So, if your “Contents”, “Introduction” and so on are regular text documents, you can set up the “Formatting” pane to have different title prefixes and formatting for “Level 1” text documents from “Level 2” documents, which would be the documents inside your other folders. That’s entirely up to you, though.)

Ah, that’s not something that’s possible, I’m afraid. Scrivener doesn’t support hiding documents in e-books like that. The only way you could achieve that is by editing the .epub file itself - you’d need to unzip the .epub file and then change the value of “linear” to “no” in the “spine” element of the OPS file, then repackage the contents into an .epub.

All the best,
Keith