First lines still indenting after compile

I’m probably missing something, but for some reason my scrivener (V3 for windows) is still indenting the first paragraph, after the chapter heading.

i’ve tried every box in text layout, and nothing happens. I’ve also used every setting below from “text and notes use custom formatting,” to “editor formatting,” and nothing changes–the first paragraph still has an indent. And yes, I did check to make certain that I hadn’t just had a brain fart and manually indented the paragraphs :).

Now, I’m fairly certain that since this used to work, I’ve managed to do something to override the compile’s formatting selections, but for the life of Me, I can’t figure out WHAT I did, so any help would be most appreciated.

Hi @cgray77 !

The cause lies probably in the compile settings. Take a look at which section layout your document is assigned to. Start at your document and determine, which section type it has. You can see that easily in outline view or in the inspector. As you are mentioning a chapter heading, chances are your document is of type “chapter”. Then open the compile options (Ctrl+Shift+E) click “Assign Section Layouts” at the bottom of the middle column and you will arrive at one of the key dialogs of Scrivener: the “Assign Section to Layout” dialog. In the left column you see your section types and in the right column you see all the section layouts of the currently selected format. Click your section type in the left column and find the section layout on the right that gets (or is) highlighted (a blue frame in my settings).

Most likely the assigned section layout is one that has the first paragraph of the text content indented, for example like this:
image
What to do now? Just assign another section layout that has not this indent and then recompile.

If this didn’t help, just let me know what you are compiling for (PDF, Rich Text …), which format you are using (e.g. “Non-fiction Manuscript (Courier)”) and what section type assignment you are using (e.g. Chapter to Chapter). We will then try to work it from there.

I was keeping the headings in their own section with no body text in them, so I’m not certain if that’s it. I checked the assigned section layouts, and my current body is “as typed in the editor.”

I’ll be looking into this more, but since this project is on a deadline, I made a work around with “first paragraph no-indent” style, which was more or less what I did for Scrivener 1, so until I get that fixed I can keep working on it.

Thanks!