[FIXED] Scrivener crashes on opening project

Today I went to open my main project on Scrivener for Windows, only to have it crash during open (no window showed up; no error message). Alarmed, I went to my Mac, where it still opens perfectly (thankfully).

Some details:

  • The file was originally created with the Mac version of Scrivener; I believe it was with v1.54, but it’s been a while.
  • Other projects will open fine in Windows
  • I tried opening another project first, and then this one, but it still crashes
  • Running Windows 8.1 64-bit
  • Running current version of Scrivener for Windows - v1.6.1.0

I’m not sure what other details are relevant, especially since it displays no error message. Any help is appreciated.

UPDATE: Reinstalling Scrivener fixed it.

Is Scrivener actually crashing, or is the project simply not opening? You mention sharing the project with your Mac, so I’m wondering if this is a less sinister problem of just having some conflicted files within the project that are preventing the Windows version from opening it. Using Dropbox or other synchronization service can do this.

I’d make a backup of the project on your Mac (File > Back Up > Back Up To…), close the project in Scrivener, then Ctrl-click its .scriv file in Finder and choose “Show Package Contents”. Are there two copies of the project file inside? (Yellow icon with the Scrivener logo, named for the project, with a .scrivx extension if you view those.) If so, move the older copy out of the project. Check through all the contents for any duplicate files or “conflicted” files and clear them out so there’s only one copy; move the extras to another folder outside of the .scriv package so you can review them at your leisure in case there’s anything you need to copy out. (That will really only matter for the .scrivx file and for anything in the Files/Docs folder.) Once you’ve cleaned it out, let the whole updated project sync completely to the Windows computer, then try again to open it there.

If that doesn’t seem to be the problem, more details would help–how are you transferring the project, did you last open and edit it on Windows or Mac, where is it stored (SkyDrive on 8.1 has been causing problems for a lot of users), did you import or copy anything new into the project the last time you used it. Also for the crash, again, is it in fact actually crashing, i.e. if you have another project open and then attempt to open this one, does Scrivener quit? or does this project just not load?

Thanks for the reply. Scrivener seems to actually be crashing–Task Manager says “not responding” if I open the project after launching Scrivener, and the Task Manager doesn’t show the Scrivener process at all if I open the project from Explorer.

I do use Dropbox; however, I follow the safe practices as outlined on these boards–namely, I’m always certain to close it fully before opening it on another computer. I last edited it on the Mac; didn’t import or copy anything new.

In your first post you say that you believe the project was first created on Mac version 1.54, and what you say sounds in part as if you are opening it for the first time on Windows. Am I right? What version of Scrivener do you have on your Mac that you’ve just tried it on? Unless you’re on 2.x, the project won’t open on Windows, and as a non-techie I’d think might crash the program.

Mark

I have 2.x on my Mac (whatever the newest version is). I’m 90% certain I’ve opened the project on Windows before, back when I used it as a trial several months ago. I only recently bought the Windows version during the recent sale.

An update:

Last night, upon opening it on the Mac, Scrivener told me the project was open on another computer and asked if I would like to work on a copy. I said yes. Once the copy was created, I closed the program. I then waited for Dropbox to sync, then turned on my Windows PC, waited for it to sync, then tried to open the project.

Same result as before. The window briefly opens (all white with the standard Windows window border), then closes.

Is there some sort of error log I can check?

Well, a little embarrassing I didn’t try this sooner, but…

I just reinstalled Scrivener. It works fine now. So this thread can be disregarded now.