Folder Level 1 Formatting not registering?

I’m pretty sure this is a bug, though I’m not entirely confident of my skill on Scriv3, so…
In Project Settings, I have set my level 1 folders to Default to Heading 1 (see attached). I have set my Compile settings so that Heading 1 is Times New Roman 20. In the middle column, however, it is showing the level 2 settings in that box, rather than the Level 1 settings. When I click on the popups (the little pen in the top right corner) both for Heading 1 and for Heading 2, they say "Edit folders (Level 2). When I click into the edit folders, Level 1 is not bolded, though I have many Level 1 folders. When I click onto the settings for Level 1, it is, indeed, TNR.

Check whether documents have the section types you intend. I suspect that setting a default takes effect only for new documents created after you set those defaults … and maybe not even for those. Set the section types you want in Editor or Compile/Contents.