-- followed by > turns into arrow

My copy of Scrivener (only Scrivener, not my other writing programs) changes – followed by > automatically into an arrow. How can I turn this off? I’ve searched everywhere, but I can’t find it.

Check Options -> Corrections -> Edit Substitutions … and turn this special substitution off or delete it completely.

That describes the process on Windows, which was built as a substitute for a global Mac feature, which is accessed in the “Text” tab of the Keyboard System Preference pane (there is also a convenience button in the Corrections preference pane within Scrivener). It is possible to have substitutions turned off in a general way on the Mac (I don’t use them for instance, as I have a dedicated text expansion tool already) but enabled for specific programs.

Speaking of which, if you run anything like that you might as well check there too. With the one I use, Typinator, it is possible to add auto-corrections to specific applications.

Thanks both for your answer.

But the problem is that for some reason the transformation of this sequence takes place only in Scrivener, not in e.g. Nisus or Mellel. So it’s not system wide, and indeed under System Preferences > Keyboard > Text this replacement doesn’t appear.

And I owe Typinator too, but 1. this transformation (or expansion, as it’s called there) is not in my Typinator lists of expansions, and 2. the problem persists even when Typinator is closed down.

So this transformation is triggered by something else; but what? Could it be some hidden option inside Scrivener?

I am not rightly sure what is causing that, it isn’t something that happens on a default install in a new user account at any rate. I do get the double-hyphens turned into an em-dash, but the result is an em-dash followed by a >, two characters, not one arrow character. There are no hidden options in Scrivener that would change that, and its own built-in completion options wouldn’t work this way anyway as they are completion, not substitution pairs, where “omw” can become “on my way” but in a completion “omw” must be the first three words of the thing being suggested—or in this case, the hyphens must be a part of what becomes, and besides you would get a suggestion drop-down when that happened, not outright substitution as you type.

In the meantime, I discovered that this substitution takes places only in one particular font, in some applications (Scrivener, Nisus, Devonthink), but not in others (Mellel, Textedit). So changing the font solves the problem.

But I still don’t understand the mechanism that triggers this substitution.

Ah, it might be a ligature then, such as what you get in some fonts when typing fi, where the cap of the ‘f’ forms the dot of the ‘i’, or some other similar mechanism. You could first try the Format/Font/Ligature/ sub-menu, but if the character doesn’t respond to that, the more complete typography palette can be accessed off of the gear button in the standard Cmd-T font panel. I’d play with any settings that look remotely plausible.

Is it a system font by the way?