Font behavior following Heading 1?

Just upgraded to Scriv 3. I use No Style set to Helvetica Regular 14 in the editor panel.

When I invoke Heading I (Helvetic Bold 18), the next paragraph goes to Palatino Regular 13 instead of returning to Helvetica Regular 14.

How do I get Heading 1 to return to Helvetica Regular 14?


Select a paragraph which you know is in Heading 1, then Format > Style > Redefine Style from Selection > Heading 1.

You’ll get this dialogue box:

Check what you have in the ‘Next Style’ drop down list; it needs to be ‘None’ if you want the default No Style to follow all Heading 1 paragraphs by default. It sounds like you may have another style selected instead.

If it is set to ‘None’, then we need to look at other solutions.


Another thing to check on is what you mean by setting the “No Style” to a particular font; it’s a way of referring to things that Scrivener wouldn’t use as “No Style” itself isn’t really something you can change, it’s a reference to default editor settings.

Seeing as how you describe the behaviour as dropping to Palatino 13pt, which just so happens to be Scrivener’s default for unstyled text, maybe you’re setting the font in the wrong place. Try in the Editing: Formatting preference pane.

BR, thanks!

Following your directions, I get to the dialogue box you show. Next Style shows as “None,” but other settings are different:

Shortcut: Option-Command-4
Formatting: Include font family is deselected

Should I change them to conform to what you show? Or something else?

BTW, I woke up in the middle of the night to realize that I had neglected to say that this project was upgraded from 2. to 3. Don’t know if that makes a difference.

Hi Amber,

Just followed your direx and reset default via Use Formatting in Current Editor in Preferences. Heading 1 is now followed by Helvetica 14 as I prefer. Thank you! :slight_smile:

However, when I click Heading 1 (Helvetica Bold 18), I see a ruler with a number of tab stops. How can I reset the ruler to conform with the far simpler one that accompanies Helvetica 14?

Paragraph styles store tab stops as well as other formatting commands. So that must be whatever they were when you created or refined the style. I find the Format/Paragraph/Tabs and Indents… tool to be easier to work with than the ruler itself. Either works though.

Hi écrivain – glad it helped.

To answer your questions in order:

  1. The shortcut key is at your discretion. That screenshot was a just a quick example – I normally have the shortcuts set to cmd-opt-1 for Heading 1, cmd-opt-2 for Heading 2 etc, but it’s entirely up to you so change it as you wish.

  2. ‘Include font family’. If you have it ticked, then your headings will always be the same font, no matter what they were in the style you’ve changed from or the default… If you have it unticked, then Heading 1 will assign the font-size / colour / paragraph spacing etc to the existing paragraph, but leave the font as it is. Again, it’s your choice.

  3. Simplest way to reset the tabs in Heading 1 is to select some text in that style, then drag the tabs around till they’re the way you want, then just Format > Style > Redefine Style from Selection > Heading 1 again. OR… you can go to a paragraph in ‘No Style’ and click cmd-ctl-c to copy paragraph attributes, then go to a Heading 1 paragraph and click cmd-ctl-v to Copy Paragraph Attributes, before redefining the style as before. NB: this will also change some other settings (such as indents, paragraph spacing etc) so you may have to change them accordingly before you redefine.


brookter and AmberV, Thanks for taking the time to explain! I appreciate your help. :smiley: