Font Bug?

I am a new user of Scrivener for iOs.
I am now trying all features to start learning the program.
Every time I click on the font/font size to try to change, Scrivener bombs out.
I am not sure if it is a bug or if I am doing sometjing wrong.

Thanks to Vicki from the developers, I have solved the problem.
I have uninstalled all non-default fonts and it is working again.
I am re-installing fonts and test scrivener after each one.

I also may be having a font bug.

When I copy text from another source and paste it into a blank document, it looks like this:

The spacing is set to 1. But if I make it bigger or smaller it stays like this. The font is Charter which I have been using successfully for quite some time. But even if I try to change the font to another, it still looks like this. Please help.

Something you could try-
In the document, tap and hold until the Edit menu (the black popover) appears.
Tap Select All.
Enter the Formatting Palette by tapping the Paint Brush in the Editor header bar.
Tap Formatting Options.
Tap Use Default Formatting

I did that. Now it looks like this.

If you’re still stuck on this and someone doesn’t come by and help solve it, you can contact Literature and Latte using either the contact form or iOS email address, accessed here:

(If it gets solved through support channels and you have the time, come back and post the solution. It might help others.)