Font Change Failure in Preferences > Appearance > Index Cards > Font

I can’t say for sure that this is new with 3.1.2, but I can’t recall having the problem before, and I am a hopelessly addicted font tweaker…

Here’s what I did:

  1. I had my cork board displayed in my project and brought up Preferences > Appearance > Index Cards > Fonts
  2. I tapped on the font icon next to the Index Card Text: sample to bring up the fonts dialog.
  3. I was happily clicking on various monospaced fonts and sizes (NOT using the size slider, so I’m sure the sizes are present in the fonts) when…

The font switched to Helvetica. After that, no matter which font I clicked, the font remained stuck on Helvetica (a disaster to a monospaced font addict! :smiley: ) The only way to change my index card text font was to quit Scrivener, re-open Scrivener, and go back to the Index Card prefs (without tweaking so much!)

This is repeatable. It will happen somewhere between five and twenty font tweaks. For reference, I have these non-Apple mono fonts installed: Ubuntu Mono, Courier Prime, Courier Prime Code, Courier Prime Sans, Camingo Code, Cousine, Fantasque Sans Mono, IBM Plex Mono, Office Code Pro, Source Code Pro.

The failure happens with these, but I’ve also seen it happen with the built-in Courier and Courier New fonts.

Ways I tried to get around this:

  • Opening a different project. No good.
  • Having no project open. Still sticks.
  • Trying TextEdit. I was up to forty font changes in a plain text TextEdit document and had NOT gotten a “stuck Helvetica.”
  • Rebooting the Mac. Still experienced “stuck Helvetica” in Scrivener.

Any ideas?

I cannot reproduce the issue, I’m afraid. I have tried clicking through fixed width fonts dozens and dozens of times with no issue.

I’ll see if I can get a project to you that does it.

Actually, the culprit appears to be the Camingo Code font. If just clicking it doesn’t do the trick, changing its font size and then clicking on a different font seems to get it every time.

Again, no problems with Text Edit on a plain text or an rtf document.

I’ll attach a project that exhibits the problem, as well as a zipped version of the Camingo Code font. Nonetheless, I can hardly blame you if you don’t pursue this further. :smiley: It’s a free font, it may have gotten messed up in the many times its been copied (although my source, fontsquirrel.com, has been reliable until this.) Thanks again for taking the time you’ve already spent on this issue.
TestCamingo.scriv.zip (285 KB)
camingocode.zip (166 KB)

Eureka! I found the trigger.

It’s not the font or the font change, it’s the font size change. I can change fonts all day, but when I start fiddling with SIZES, it’s not long before the font switches to Helvetica and locks!!!

Try switching the index card font while you can see the cork board, change sizes a couple times, switch again, change sizes again. It needn’t be a monospaced font, (although why anyone would want a proportional font for index cards… never mind. I know I’m weird. :smiley: ) The Helvetica lock is triggered by a size change.

Sorry for the late reply. It turns out that this is a nasty system bug. I found, in fact, that I had already written some work-around code for this bug after it first reared its head in High Sierra. It seems that certain fonts - only a few of them, such as Hypatia Sans Pro and OCR A Std - cause the font panel to report the chosen font as “Helvetica” when they are converted from another font (which is what happens internally when changing fonts in the font panel). So even though the font panel is showing the correct font, it is sending out Helvetica to the objects that are listening for its changes. It seems that the workaround no longer works as of Mojave.

I can’t find any way around this, unfortunately. I’m not sure why the bug isn’t triggered by changing the font in text - but that’s a black box in Apple’s code. The font changes in the Preferences are all done according to Apple’s docs, and there is no other way of doing it - and there’s a bug in Apple’s font panel where it is sending out the wrong font (Helvetica) in certain circumstances. Hugely annoying. I’ll try to put a sample project together for Apple to report it as a bug.

All the best,
Keith

Thanks for persisting with this! Apple’s bug, eh? And no workaround. Ah, well.

I’ve submitted this to Apple as bug ID#50338324. Annoyingly, it was much harder to reproduce the bug in the sample app I produced for them, for some reason - I only managed to get it trigger once. Weird.