font issue in complie/proofing leading footnote superscript

Hi,

using Scrivener 2.4.1 (22494) under Mountain Lion I have encountered an issue when compiling into Proofing mode (I need footnotes at the bottom of each page instead of endnotes and that is apparently the only way to achieve this?!).

In one section of my document, the body text leading a certain footnote superscript changes font (size and bold, not family) as soon as it is compiled. In the Editor everything looks fine. I have reformatted, preserved, even retyped the offending text: no change. Then I moved the footnot marker up and voila - the font change affects only the text preceding the footnote marker.

In the first screenshot you can see how the text preceding footnote 17 is bold, and there is nothing in the formatting, Editor or Compile settings I can apparently do about it.

As soon as I insert an additional footnot after the first word of the text in question (add’l footnote 17 now just reads “text 1” at the bottom of page) the error is confined to the text preceding that footnote marker, see second screenshot below.

Have I overlooked something real obvious (bit of a newbie in Scrivener), or is this an actual bug? Any help is greatly appreciated, as the manuscript is, of course, overdue.


Hi,

For the “Proofing” PDF export we pipe RTF through a third-party converter to produce the PDF file, so it’s possibly a bug in that. (In general, if you require end-of-page footnotes for something more than proofing a document, it’s much better to export to RTF or Word and generate the PDF file from a dedicated word processor). I haven’t been able to reproduce this issue for myself, though. Could you please send us the project that this happens to so that we can test it? I can report the bug to the people who make the converter then.

Thanks and all the best,
Keith