Font Issues in Novel Format

I feel like the village idiot asking this question, but I’m trying to set up my manuscript, and I can’t get the existing font/font size/ spacing to change.

Right now it’s Cochin, size 14, 1.2 spacing.

I need Times New Roman, size 12, 2 spacing.

I can change it in the drop down menu, but then it reverts to original.

Help…

Editor formatting is only specific to the bits of text you change. So if you make a change to the formatting in one paragraph, then as you type on from that paragraph those changes will remain, but nothing above that point will change. If you type into a section above that point it will still have the old formatting. There are two things you can do:

  1. Change the default formatting of the software. This is done in the Formatting preferences pane. The easiest way to set things up is to find a paragraph you’ve formatted correctly, and put the cursor in it. Then use the button in this preference panel to use current formatting. It’s at the very top-right above the mock editor. You can make changes in this editor frame as well. That will make it so all new documents are set up the way you want. You can use the menu command, Documents/Convert/Formatting to Default Text Style to reformat existing documents to the defaults.
  2. Let the compiler handle it for you and don’t bother in the editor. In fact, if you’ve changed nothing in your current compile settings yet, and are using the novel template, you should be able to see a practical demonstration of this happen just by testing compile once. You should see all of your work end up as 12pt Courier double spaced. So in your case, all you would need to do is change the global font override in the Summary tab of Compile to use TNR instead of Courier. Then you can write in whatever font you please in the editor. And of course, the first point is still useful if you choose this way of working. You might not like Cochin, for instance. For example I use a fixed width font when I write, but I rarely ever output using a fixed width font.

Hi. I’m having the same problem, and I haven’t been able to get the fix AmberV suggested working. I prefer writing in 18 pt Courier–old habit. But I can’t get it to stick. Here’s what I tried:

  1. Before creating my new project, I went into preferences and changed the main text style to Courier, 18pt.

  2. Created my new project (BBC radio scene template). The font was 12 pt Arial.

  3. I figured, okay, the template is overriding my global selection. I select all, change the font to 18 pt Courier. I type a line, and it’s in 18 pt Courier. As soon as I hit enter, it starts a new line in 12 pt Arial.

  4. I go to Project > Text Preferences, check “Override text formatting for this project,” and set it to to 18 pt Courier. Every time I hit enter, it starts a new line in 12 pt Arial.

I’m not a big fan of writing in variable width fonts, and Arial I find particularly egregious. As petty as it may seem, this is kind of a deal-breaker. Is there any way to make my preferences stick? Thanks in advance!

Sorry to make this two posts, but I just had a thought to add to the above:

The BBC radio scene template has different formattings for dialogue, scene headings, technical directions, etc. Perhaps I have to change font defaults for each of those categories? I couldn’t find a preference pane for that, though.

For this you would have to edit the script format itself (Format > Scriptwriting > Script Settings…).

Beautiful! Thank you, KB! Worked like a charm.