Font keeps changing

The font on my document pages keeps randomly changing as I type, from Optima to Lucinda. I can’t figure out why or when exactly it happens (seems like it happens sometimes - not always - when I hit return for a new paragraph, and/or sometimes when I backspace to delete something) Is there a setting for that? I checked preferences but I don’t see a place to set the font for the body text. I’ve tried highlighting the page and even the whole Manuscript folder and setting the font to Optima but it still happens.

Unfortunately my guess is that you recently upgraded to Snow Leopard - this seems to be a bug Apple introduced to the text system in Snow Leopard. I’ve seen it myself and have had several reports on it, but if you can find a specific situation in which it always occurs, please let me know, as it may help me find a workaround.
Thanks and all the best,

No, I haven’t upgraded to Snow Leopard. I did recently download Scrivener 1.53 and I’m using the NaNoWriMo template. I’ve been using Scrivener for several years and I don’t recall having this problem before. I’ll try to figure out what happens before it changes fonts and post again.

Interesting… So far I’ve only seen this on Snow Leopard. There are instances the text system changes back to the system font, Lucida (a bug in OS X), but it’s usually only after using bullets - I don’t think I’ve seen it in any other situation. So if you can find an instance in which it always happens, I’d be grateful.
Thanks and all the best,

The exact same thing happens to me on the downloaded the trial version for NaNoWriMo. I have not upgraded to Snow Leopard. It happens to me after I hit return.

In what particular circumstance, though? Obviously it doesn’t happen for everyone in all instances of hitting return, or the forums would be swamped and I’d be seeing it frequently too. Does it happen every time you hit return? If so, what font are you using? If not every time, in what circumstances does it happen? For instance, if it happens and then you delete the return and hit return again, does it happen again? If you then delete the return and copy and paste into TextEdit and hit return in the same place, does it happen there too? If you can find a situation in which it always happens after a certain piece of text, could you please send it to me?

It doesn’t happen every time I hit return. In a typical NaNo writing session it might happen twice. I was wondering if there is a shortcut that I’m accidently activating.

What font does it change to? If Courier, it could be that you are accidentally entering script mode (does the word count at the bottom disappear too?). Otherwise it does sound like a bug, but unfortunately I need to reproduce it - trap it before I can squash it, as it were. So if you see it happen again and can get it to repeat, that would be great.
Thanks and all the best,

My problem was caused by an un-asked-for font change, too, and I’m using Tiger. I just thought I’d let you know in case that helps. NaNoWriMo trial version.

The font changes from Optima regular 13.0 to Lucinda Grande 11.0. In every case that I can remember, it changes after I hit return. If I delete the return and hit return again it does not recur. I don’t know if this is coincidence, but it seems to happen in writing dialogue. I hit return and then quotes and then the font changes. It does not happen often. I spent a couple of hours tonight writing and it did not happen once, so make of that what you will. Perhaps the bug has spontaneously died. I hope so. Other than this tiny thing, I love the software. I’ll be back for a license after 50,000 words.

Lucida Grande is the default system font, so the font is getting reset internally somehow.

As I say, if either of you are able to get it to happen in a specific situation so that I can reproduce it myself, I’ll have a chance of fixing it. A few users have reported this, so I know it’s a problem, but unfortunately right now it seems random (it won’t be random, it just seems that way…). And the problem with bugs is, you are stabbing in the dark until you see them for yourself and check what is happening in the background as they happen.

So, I’d be really grateful if either of you can find a specific case in which it always happens.

Glad you’re liking Scrivener otherwise!

Thanks again and all the best,

This sounds a lot like the weird bug we found a while back where I do not remember the exact steps for reproduction, but there was a soft-break return in there somewhere. Essentially you could end up “outside” of the RTF formatting containment and thus the system would revert back to Lucida default.

This was a while ago, so I don’t think it was related to Snow Leopard.

Perhaps something in the Nano special version made it easier to trigger this bug?

Since there are not stupid questions let’s agree that stupid people ask questions like the one I am about to ask…

Is it possible you are hitting the alt key at the same time as the return key? I do this when using a winblows keyboard attached to the Mac. Or even hitting the “enter” key, not the return key?

Based on AmberV’s post, I did a little “sysadmin crap” and on my 10.5 MBP these both generate soft returns.

Exact same thing happening to me. Optima size 13 changing to Lucida Grande 13. For me, it occurs when I am using a (1 2 3) numbered list and hit return. Poof! The next line is Lucida. I think this is the only scenario this happens to me. I am on OS X 10.5.8. Hopefully this helps!

The numbered list font-changing bug is well known, I’m afraid - that one is definitely down to the text system; it happens in TextEdit too (which uses the same text system).
Thanks and all the best,

I’ve been having the same problem and I think I figured it out.

I’m using the NaNo demo version of Scrivener with the NaNo template that comes with it. The font has been changing for me from Garamond 18 to Lucida Grande 18.

When I’m typing along at a good clip, sometimes my fingers get tangled and I mistype. When this happens at the end of a paragraph, I can make mistakes going from the return to start a new paragraph to capitalizing the first sentence of it. For whatever reason, when I happen to hit shift-return (holding down the shift key while pressing the return key) twice in a row, the font changes from the font I’m using to Lucida Grande. On my system, at least, this occurrence is reproducible.

Hopefully this will help you track down the bug. :slight_smile:

Shift-return is a line-break or soft-break return, as Amber pointed out.

I’ve not encountered this problem myself … maybe I just don’t type fast enough … but I am driven mad by Word docs produced by my Chinese colleagues (and students who write in their CVs that they are expert in the use of Microsoft Word!) and who use soft-breaks and hard-breaks randomly, obviously unaware that there is any difference! Creates hell when trying to sort out the formatting for something that is going to be sent to be published.


Hmm, okay, based on Amber and Sarahswati’s posts, I think I know what may be going on.

There does indeed seem to be a bug in the OS X text system that causes the font to return to the system default after two soft line breaks. You can reproduce exactly the same thing in TextEdit as follows:

  1. Change the font and type something.
  2. Go to Edit > Insert > Line Break.
  3. Go to Edit > Insert > Line Break again, so that there are now two soft line breaks.
  4. Hit the backspace key to delete the last line break.
  5. Start typing - the font will have changed to Lucida Grande.

EDIT: Actually the above steps aren’t needed. Just insert a line break and then backspace to delete it. The font will change to Lucida…

What changed in Scrivener recently is that it is now much easier to enter a soft line break. The shortcut for it used to be opt-return, but following user requests to have the feature match the more common keyboard shortcut, entering shift-return now creates a soft line break. So it seems that what is happening is that some users are hitting shift at the same time as return, causing this issue.

I will take a look to see if there is anything I can do about the font change, but I would recommend anyone who is finding this is happening to retrain their fingers not to hit the shift key as they hit return, as you most likely don’t want a soft return. But most word processors - including Word and Pages - use this same shortcut for soft breaks.

All the best,

Okay, I’ve investigated this some more, and it seems to be a very strange OS X text system bug (groan). It appears that the OS X text system simply does not allow certain fonts to be applied to be a line break. To see what I mean, try the following:

  1. Open up text edit and change the font to Optima. Type something.
  2. Go to Edit > Insert > Line Break.
  3. Now select the line break by double-clicking at the end of the line you typed, so that the selection goes from the end of the last character on the line to the edge of the text view.
  4. Open the fonts panel (cmd-T).
  5. Notice that the font for the line break character is Lucida Grande, even though you were typing in Optima.
  6. Change the font of the line break character to Optima.
  7. Click somewhere else and then re-select the line break character - notice how it has changed back to Lucida Grande, even though you just tried to change it to Optima.

Thus it seems that what is happening is that internally, when you enter a soft line break, the OS X text system knows that the line breaks don’t support all fonts and revert to Lucida Grande, so lets that happen but then adjust the current typing attributes to what they were before once the line break is inserted. So if you carry on typing, everything seems fine. But if you use backspace to delete the line break character - which has been inserted in Lucida Grande - then your font will change accordingly.

There is, unfortunately, nothing I can do about this, as this is some obtuse bug within Apple’s text system that refuses to apply certain attributes to soft line breaks (but oh, surprise, surprise, it doesn’t affect Pages, which uses a different text system, grr).

The one thing I can do - and have just done - is to change it back to the old behaviour, so that to enter a line break you need to enter opt-cmd-return rather than shift-return, which means that it is less likely anyone will enter a soft line break by mistake and should to all extents and purposes solve the issue for most users.

Thanks and all the best,

Would there be a way to add an option to disable the shift-return key combo for the soft line break? That way those who wanted to use it could and the rest of us could disable it.