Font Pasting Size Bug 1.2.5.0

The bug is back.

When I cut text from one source and paste into Scrivener, I am not always able to change the font and size to my preferred choice. The font size will say -1, but I cannot change it to another size. This bug was in 1.01, fixed on another release and is back again.

The temporary solution then was to use F4 and change the font there. But that will not work for me now.

Thanks for your help!
Chris

Hi Chris,

Could you point me to a sample text that is reliably reproducing this problem? What program are you pasting from? Is it possible to select exactly the text that was pasted (nothing additional) and change the size on it that way? (Specifically when you make the selection, the text where you end the selection should have a different font/size than what you’re trying to change the whole selection to–that was a bug with this in 1.0.1 fixed for 1.0.3.) Does using Documents > Convert > Formatting to Default Text Style work to change the pasted text?

Meanwhile, you could try using Paste and Match Style to bring in your text. It will strip character attributes like italic and bold, but it will paste as plain text, consequently picking up the formatting of the surrounding text in the Scrivener document.

Thanks for the response. To answer your questions:

  1. It seems any text I copy from Google Chrome Web browser and paste in. First it was something I typed in my wordpress installation. Then it was from Wikipedia. The format bar showed the font size as -1. Below is a screen cap. Selecting just the text pasted didn’t work, as the bug used to work. But using “Documents > Convert > Formatting to Default Text” did change it, the only thing that worked for me. Not even the “Paste and Match Style” worked though.

Thanks. Definitely looks like an issue with how Chrome is passing the text; some junk formatting is getting included (testing this, I saw some problems with background colors as well as the -1 size). The same text pasted from Firefox or IE doesn’t have this problem. I’ve put it back on the bug list.

Paste and Match Style was working for me in testing, but you need to ensure you paste into a “good” space, i.e. a fresh document or into existing, properly formatted text. If you paste from Chrome and get this wacky formatting, then try to delete it or Undo and then use PaMS, it will pick up the bad formatting still.

Thanks so much for your help!