Font randomly reverting while composing in a document.

Hey all,

So I’m writing a screenplay in Scrivener, using Full-Screen Composition mode. I have the settings such that when composing, it’s “night mode” with colors modeled after iAWriter and the font set as Courier Prime Sans. It’s beautiful and has taken endless tweaking to get just right.

So it’s danged heartbreaking that all of a sudden, out of the blue, it’s stopped working. While I’m working in a document, it will randomly switch to Courier.

I’ve selected all and reset the font to Courier Prime Sans and have of course checked and double-checked the Project Settings to be sure it’s set to start new documents with the Font setup described above.

But to no avail. What’s particularly weird (and frustrating) is that I’ve gotten this all to work perfectly before. In fact, I just finished a four-month project where I worked in exactly this way!

Anyone have any hints as to what I might be overlooking? Thanks so much in advance for any insight anyone might be able to provide!

Thank you,


Just something to check first: have you been through every script element in Format > Scriptwriting > Script Settings to see that they’re set to use the right font?

Hey Brookter,

Loooooks like that might have done it! And now that you mention it, I distantly remembering doing this on the prior project early in the process a few months ago.

So call it a tentative solution and thank you very much!



Glad it helped (provisionally!)…

Note that you can define your own script format, which will include settings for all of the elements.