Font selection for top menu -- Display issue

Hello,

I regrettably changed the top menu font in the Options area to a bold font. Now that I see how it looks (it’s dominating the view and very distracting), I want to change it again. But whenever I select a new font/size/no bold, the new selection no longer sticks.

Is there something I can do to address this? Or is it possibly a bug?

Thank you,
Laurie

Hi.
I changed it to bold, then went back to normal without a problem.

Is this where you changed it from ?

If yes, try this :
Inked2022-03-12 22_58_52-Window_LI

Ultimately, if you haven’t changed that many things in the options, you could simply reset them :
(Bottom left of the options panel)
image

Yes, that’s where I changed it from, and trying to change it back from there results in the problem I described.

I tried changing back to default–it seems to go all the way back to the default in this interface, but nothing changes in the actual menus.

Click on the circular arrow I circled in my second screenshot.
Then click on the font selection button just left of it. (1st screenshot)

Tell me if this is exactly what you see :
image

Note that even if you make changes to the options (in this case the font the menu uses), the changes will only become visible in the menu once you click “Apply” or “OK” in the option panel.

The menus are in the interface, I think?

Thanks for the replies.

Vincent, re: your screen shot: This is, of course, exactly where I changed the font in the first place, hence my trying to change it back from there.

I have figured out part of the problem. The ‘apply’ button is off screen now. Can’t resize the window or move it up (tried moving it up but it pops back down so the buttons are offscreen). I’ve tried zooming/unzooming and hitting the enter button. Simply hitting entered worked for one iteration; now it only pops the selector again.

I finally resolved by hiding Windows (11) task bar. This doesn’t seem like it should be necessary, though.

Seems to me like your screen resolution is set way to low.

. . . . . . . . . . . . . . . .

That was not at all my question…

If it is fixed now, it’s all good. :slight_smile:

Probably not “to” low resolution, since it worked fine the first time and I didn’t change that setting.

Well, perhaps then by changing the options you ended up making everything big and bulky to accommodate the font you inadvertently selected for the menus.
If this happens again, one solution could be to temporarily increase your screen resolution in Windows’ display settings.

I don’t think this is about screen resolution, which I’ve never touched since purchasing this PC.

Additionally, as I mentioned above, I got the font to switch the size back (one iteration only), but even with reversion to smaller menu font, the apply button was off screen.

It seems to me that the behavior of this interface shouldn’t change like this.

Anyway, I’m happy at least that my problem is solved for now. If someone else encounters this issue, perhaps this post will help them figure out that they can work around it by hiding the task bar.

Thanks to all who tried to help.

So you couldn’t click it. Therefor being stuck with your issue. We get it.
That’s where changing the screen resolution comes in…
You kept changing the font, saying there was maybe a bug, but all this time you never clicked “Apply” nor “OK” in the options. Leaving the big bold font as it was all this time.

Vincent,

You have misunderstood, or perhaps not read all of, my earlier posts.

As I said before, with one iteration of hitting “enter,” I got the font to change to a smaller one/nonbold. I tried this because I could see that the apply button was off screen. So, therefore, I DID NOT “leave the big bold font as it was all this time.”

Using the “ENTER” key worked ONCE to “APPLY” without hitting that button, which was off-screen. It had not been off screen before – when I first changed the font successfully to bold, I hit apply. (I noticed that it wasn’t there, but thought perhaps that I had been misremembering its existence.)

After successfully using this method to change to a smaller, nonbold font, I tried to change it again. NOTE that this means the menus were small again when I tried this. The “ENTER” workaround did not work; instead, the selector kept popping up. I actually tried quitting and restarting Scrivener at this point as well.

This was when I figured out that I could hide the task bar to get more screen space.

I do not believe this is an ideal solution, but it’s easy and works. Certainly a more reasonable idea that changing the screen resolution every time I want to change a font in Scrivener.

That is simply impossible. As soon as you would have clicked the font selection button in the option panel, the “OK” button would have lost focus.

You confirm it yourself :

But you know what, lets leave it at that. You have your issue fixed now ? It’s all good.
(Either that or I’ll end up asking you why you come for help and don’t listen to what people trying to help you have to say…)

1 Like