Font Sharpness/Display changes after update?

I’m feeling like a complete idiot, but I just installed the 1.9.5 update and sat down to work on the new book… and I cannot stand the sudden change in appearance between 1.9 and 1.9.5 - all of the clarity has gone on the fonts on my Lenovo (x1 carbon running Win10) - the menu bar stuff lacks definition, the font in the main project has changed to Courier New and lacks any sharpness. I’ve tried fiddling in options/appearance but I cannot get it to look like it used to, and right now I can’t focus on the screen to write. It’s driving me crazy. My first thought is to rollback my installation, but of course I can’t find 1.9.0 to do that… I’ll admit, I’m really frustrated as I’ve wasted 2 hrs of the writing day so far, and can’t get anything approaching a decent appearance. And it’s only in Scrivener - all the fonts on the browser etc are scaling nicely, sharp, with definition etc. Has anyone else had this issue and found an easy fix that doesn’t involve doing the time warp and going back to yesterday?

YES! I have the same issue, and it’s making me crazy. Following this thread for any fixes. I also emailed

Ditto for me. Same issue. I have a long report to write up and it sure would be nice to have clearer fonts. Any help would be appreciated.

UPDATE: I just did the following and it worked for me. YMMV.

The problem in Windows 10:
When you have a widescreen, with a resolution of 1920x1080 or higher or a bit lower, in Windows Vista, 7, 8 and 8.1 you would put your DPI scaling to 125% or higher to make text and images appear larger and more easy to read.
But when you put the DPI scaling to 125% in Windows 10, you see in a lot of dialogs and windows the font gets very blurry.
It does not matter if you are using the regular or custom Windows DPI scaling functions at your ‘Screen properties’. Text will get blurry on 125%.
You can test if you have this bug also if you put your DPI scaling to 125% at your ‘Screen properties’, then reboot Windows (or sign in again when it asks you).
Then goto ‘Control panel > Administrative tools > Services’.
If you have this issue also you would see the titlebar of the Services window has a font scaled good. But the services list itself is very blurry/unsharp to read.

The SIMPLE fix:
Right-click on the shortcut to your application that has blurry fonts, then select ‘Properties’. Then tab ‘Compatibility’. Then enable ‘Disable display scaling on high DPI settings’ and hit ‘Apply’. then restart your application, and you see it will look good.

Yes! That worked! Thank you so much.

You are a genius, thank you so much! Just saved me rolling back, and that means I can use my iPad too.

Note - this is not really an acceptable workaround, this causes the UI to be rendered at half size.

So the two choices with 1.9.5 are:

  • render at half size, display scaled up with everything blurry and unreadable (out-of-the-box experience with Scrivener 1.9.5 on Windows);
  • or, with this workaround of setting Windows to use legacy app compat DPI, render at half size and display at half size with everything tiny and unreadable.

This needs to be fixed, I can’t imagine how the release got past QA given that 1.9.5 was supposed to address DPI issues, but there you go. We’re all waiting for 1.9.6 now!

This did it for me. Thank you! Already, the headache was on me…

Of course the latest windows update this morning killed the work around so I had to do it again. But hey, it’ll be interesting to see how this looks on the new Lenovo Yoga X1 that arrived today… the screen on that thing is a thing of beauty… so I’m sure it’ll be a nightmare hah.

Thanks for the short term fix. Stunning that this update fails so badly at fixing the high dpi issue.

Hi zachyg, I can sympathise with your frustration, but what they did was at least deliberate. They’re working hard on hard on Scrivener v3, and they know that the changes in 1.9.5 aren’t a full fix; they just chose to ship something in the meantime that they thought would help, so kudos to them for making steps in the right direction. Scrivener 1.x is stuck on an older version of Qt where they can’t add DPI-awareness without a certain amount of work.

Although I totally understand what you are saying, let us not forget that 1.9.x is still being sold. So, it must be supported, therefore knowing that LL is working on a v3 is no real satisfaction for those who (in particular recently) bought 1.9.x.
Version 3 will be paid, as we all know…

A new paid version can be totally justified by new features it brings with it, but not reasoned with bug fixes for bugs the 1.9.x version has.
If I buy it today, I must expect it to support recent hardware…otherwise it should be stated somewhere that it doesn’t…

Having the same issue. I’ve posted a couple of screenshots on Twitter here: … 0327642112

Using a Surface Pro 4. Not sure I want to choose between a sub-par writing experience or a teeny tiny UI. May be useful, in a future update, to be able to change the size of UI to suit the user / make it more adaptable for people who have sight problems, for example…