Font shrinks when cut and paste[BUG LOGGED]

Sorry if this has been recorded, but I have searched and haven’t come across anything similar.
I am using beta 1.4 Windows VistaS SP2.
It is a simple thing. When I cut and paste text, the pasted text changes font size and font. I have Verdana Regular 10 set as the default font. When I cut something in that font and then paste it elsewhere, (in the same document or in another document) the pasted text changes to MS Shell Dig 2 Regular 8.

Just came by to report the same issue. The bug is the same (same fonts, same sizes), but I’m using beta 1.5 on Windows 7.

Hi,

Have you tried “paste and match style” ?
In most cases, this helps.

I have the exact same problem as tgif0. Same fonts. I’m using Windows Vista 32 bit, for what it’s worth. It does not happen 100% of the time. It keeps happening when I’m not expecting it, and then I cannot reproduce the error, so I don’t know whether paste and match style would help. I cut and paste using ctrl-x and ctrl-v.

Since the text I cut out was generated while typing in Scrivener in Verdana 10 point font and the text around where I pasted it was also in Verdana 10 point, I don’t understand where this MS Shell Dig 2 Regular 8 comes from.

Update: paste and match style still produces the 8 point font I got with regular pasting.

I keep having the same problem - also intermittent - and it is very frustrating.

For instance, today I tried to copy some text to a new note, and it changed it to a different font and tiny size (-1), and try as I may, I can’t get the -1 size to change to anything bigger. I click a larger size, but nothing happens.

It also happened a lot yesterday when I tried to rearrange text in my main writing area (not screen-sized, not tried that yet). The pasted text was a different font and tiny, although I managed to change it to bigger then - but not today.

Sorry - I forgot to mention. I am using Windows Vista 32

One Method of Reproducing Bug (With 100% Success)
(Win 7 Professional 32-bit, Chrome browser, Beta .55)

1. Create New Blank Project. 2. Select "Untitled" document in Binder and press Ctrl+N. 3. Find something on the internet to Copy (Ctrl+C). (Substitute any external application, Notepad, Word, etc) 4. Paste into one of the documents using "Paste and Match Style" (Ctrl+Alt+V). Text should appear and match default font/paragraph settings. 5. Select pasted text within Scrivener (Ctrl+A). 6. Copy selected text (Ctrl+C). 7. Paste selected text (Ctrl+V -- not "Paste and Match Style"). Text will appear in MS Shell Dlg 2 size 8.
This appears to be 100% consistent when Copy/Pasting from any external application, not just Chrome (internet), which makes sense. It even happens from Notepad, which shouldn’t carry any style characteristics over into Scrivener…

However, it is still an intermittent issue when dealing with existing projects and not starting from scratch.

I can reproduce the problem every time with Scrivener 1.55 and Windows XP, pasting from Notepad, Chrome or Word 2010. Pasting to match style does serve as a workaround, but it’s frustrating when I forget and use the standard CTRL-V.

Even when pasting from formatted text, I would like the option to set the default to match my Scrivener settings. I think it’s rare that a manuscript doesn’t use standard text throughout, so the need to paste with formatting should be the exception.

Correct. It’s most frustrating when copy/pasting randomly produces the bug (ie, not from an external source, which happens, though rare)… Hopefully this reproduction is enough to determine the issue and resolve the intermittent issues.

I agree; it would make a lot of sense to have the default switched.

I note the above bug has been logged, but I thought I’d just add my experience to the pile:

  • Copied from Google Docs in TNR 12 Norm
  • Straight Paste into Scrivener - TNR 8 Norm
  • Ctrl+Z to undo - tried to fix font - pull down menu drops down, but only option that can be selected is 8.
  • Blanked and deleted Scene.
  • Right Click on Chapter -> Add new text
  • Drop down menu now works, select font size 12.
  • “Paste and Match Style” -> TNR 10 (WTF??)
  • Ctrl+Z - Reselect Font Size 12
  • Tried typing a sentence directly - auto reset to TNR 10.
  • Selected sentence, tried to resize - Drop Down Menu only allows size 10 to be selected.
  • Blanked.
  • Pasted selection into Notepad, recopied.
  • Pasted into Scrivener. TNR Size 10.
  • Selected text in Scrivener - attempted to resize to 12. Resized to 8. Ctrl+Z took me back to TNR 10.
  • Took Scene where “Paste and Match Style” had worked -> Duplicated. Moved to proper chapter. Selected text. “Paste and Match Style”. TNR 12 - Success!

([size=50] Edit: Having been informed that personal emotional outbursts have no place in bug reports, I have removed them. However I still think that banging my head on the table might have helped a little and should be noted by people attempting to recreate my results. :smiley: [/size]

This happens to me too. I’m using Windows XP and Scriv 0.29.