Font Size Not Recognized & Photo Captions

  1. I have credits under images that I have used the size 9 font, while the rest of the book is in 12 font. But when I compile for PDF (for paperback) the font size shows as 12 points for the captions. How do I make it accept the smaller font?

NOTE: I do not have the option checked to override font.

  1. Is there a way to add captions to images?

Thanks.

You need to use “Preserve Formatting” for the credits.

:slight_smile:

Mr X

Thank you. Where do I find that?

Format > Formatting > Preserve Formatting

:smiley:

Mr X

Hi Mr. X,

It still does not recognize the smaller font under the image. Is there another way?
Is there a way to add smaller font caption (photo credit) under my images?

Would it be possible to create a very simple sample from a blank project with one picture, one caption, two placeholder paragraphs around it and your compile settings that demonstrate the problem? I’ve attached my own, and without formatting override in the compile settings there is nothing changing the font size of the text as I set it in the editor.

In answer to your other question: no there isn’t a caption feature in Scrivener.
16104894-Scriv-caption_demonstration.zip (6.4 MB)

I can create a screencast of the issue and send you the link. Would that work?

Here is a screencast of the issue:

quick.as/Bm1asDynQ

That works, thanks. Three things worth note:

  1. The place where font sizes and other formatting attributes would be overridden is in the Formatting compile option pane (checkbox along the top). You had left the focus on the Quick Font Override pane which, even if you were using it, doesn’t touch font size—just the font face.

  2. Not really pertinent to what you would need to get this working, I believe, but Preserve Formatting is a type of formatting itself and is applied to text like you would apply formatting. For example if you put your cursor in the middle of a line like you did, and used Format/Font/Bold, nothing would happen. So that’s why the assignment vanished when you checked the second time, it was never applied to the line to begin with.

That aside, like I say, I don’t think you need Preserve Formatting here unless you really actually do want formatting overrides in the compile settings. If you do, you would select the caption line and use the command (it’s visually very obvious when applied).

  1. For sections like the bibliography, where the entire section has special formatting, you could use Preserve Formatting, but a better tool might be the “Compile As-Is” checkbox in the Inspector. That will opt the entire bibliography section out of anything that happens in the Formatting compile pane.

What worked is I highlighted the text then used PRESERVE FORMATTING and that worked. Without highlighting, it doesn’t work.

Thank you for working with me.