Font sizes not respected in Scriviner 3

Scriviner 3 has been a very very very painful upgrade.

I’m not using styles. I’m just trying to change font size on my title page. It doesn’t seem to be respected at all. I’ve even change font size to 96pt just to make sure I’m not crazy and it still didn’t change the size of font.

After unzipping the epub and comparing the xhtml using computed layout with chrome’s inspect:
version 1:

version 3:

with 96 font size as the extreme example, its bounding box is expanded, but the text looks like the default size, making it look even more odd.

If something as simple as selecting a font and font size with the format bar is not dependable, then maybe I’m better off going back to version 1. What am I missing?

If I understand correctly, you’re just changing font sizes without any kind of indication in the text of what the font size change is for? So in other words if you had 12pt in half the novel and 14pt in the other half because you changed font defaults halfway through writing, you would expect half the book to display differently to the reader? Probably not! The compiler is designed to clean up that kind of stuff for you.

If you’re changing font sizes for some specific purpose, you should be using styles for that. Captions, minor headings that don’t need to be in the ToC and that sort of stuff would all be something you’d want to indicate as meaningful in some regard.

so I have to use styles for any font change or it will just disappear when I compile?

Every word processor I’ve ever used has respected it if I select a paragraph and change the font for that selection, it changes the font for that selection. So you’re saying it’s no longer relevant what the font is unless I use styles? That’s counterintuitive and aggravating, but I’ll give it one more day to get that working. Now I have to figure out how to associate a style with formatting. Back to the manul.

Just select some text that looks right, and use the Format ▸ Styles ▸ New Style from Selection... command to set it up. If you’re working with styles a lot, the Styles Panel in that same menu will be more convenient.

1 Like

In Compilation, a myriad of settings will influence the results for an e-book. In your v3 image no font-size is defined in that style, so it gets its size from somewhere else in the stylesheet.
I’d format the text of the Title like you want and create a Title Style from that. That’s an Editor Style that works for the Editor while writing.
At Compile time, copy the Editor Style called Title to the Compile Styles and your formatting should show up in the generated Stylesheet and end up in your e-book.

File > Compile, Double-click the Format you use and select Styles in the menu at the left-hand side of the Compile Format Designer (check the window title to see if you’re in the right window). The Import Editor Styles function is the plus-sign icon at the top right of this screen. Check the formatting in the formatting Editor. In the CSS tab, look up the resulting CSS in the bottom right pane with the Default Stylesheet. It should have the correct font-size in your Title’s Style…

CompileStylesPanel

Hope this helps

2 Likes

Not really. You could compile your draft “as is” to docx format, for example. But one of the features of having an explicit compile step is precisely the ability to compile the same material differently — and not just to different file formats, but with different stylistic features like base font and font size. Thus, a compile format may be set to override the basic look of your paragraphs in the editor so as to apply different features — a more finished look perhaps. Note that what sort of compile options you have will be in part dependent on the fact that you are compiling to epub.

1 Like

That’s needed only if you want to override the style, making it different from what it does in the Editor.

2 Likes

I don’t see flatten on first indent in my styles screen. Other than that nice to have, I’ve been able to get my book in decent shape with everyone’s help.

1 Like

It’s a Compile setting, not a styles feature. It couldn’t be placed in a style, since it’s on the level of a section type, not a paragraph.

1 Like

There are settings for flattening indents on styles, as well as flattening the indent of anything following the style, but these settings are available to word processing-based and PDF outputs. Ebooks are handled differently because they use HTML and CSS for formatting—and they don’t have indent controls in the Layout’s settings, as per your screenshot.

Indent control looks like this:

  • RTF-based:

    • Section Layouts: Settings tab: controls the overall policy for indenting text that isn’t styled—so in most cases all body text.
    • Styles: individual styles can override the indent policy of a Layout on a per style basis. They can be set to equalise left and right indenting to keep the text block in the middle of the page, and control the first-line indent for themselves and the text following them. A Caption style might for instance cause the next paragraph to not have a first-line indent.
  • Ebook:

    • Text Layout: all indent settings are handled in this pane. There are no settings for first-line indent in Styles or Section Layouts.

    So in a sense the front-end controls for ebooks are a bit more limited, however since ebooks use CSS for formatting, and the CSS of the book is completely exposed and editable in the pane for it, one can indeed apply whatever indent policy they want to individual styles, which at that point cease to be styles in a word processing sense, and become classed HTML elements.

By way of example, if we style some text as “Monologue” in the editor, this text would come out like this in HTML:

<p class="monologue">Blah blah...</p>

The formatting we supply in the Styles pane would automatically generate CSS for the .monologue class, but we could go in and override that, doing whatever we want with it:

.monologue {
	text-indent: 0rem;
}

That would suppress all indenting for these paragraphs, regardless of higher level global settings to the <p> element.

1 Like

There’s the context I was missing, it’s only certain formats. That explains why this video does the straightforward approach of using two separate styles to flatten first indent, with first paragraphs being a different separate style (normal and normalStart).

tl;dr

I did read it, but I’m flummoxed. Somewhere in all that did you mean to say, “We cannot create a style with that feature, but you can make it happen in CSS”?

That’s not the same thing as stopping the first line indent.

Yeah, personally I’m not a huge fan of that approach in a program like Scrivener. It feels to me like a carry-over from word processing which tends not to have procedural indent handling. With Scrivener you can just leave styles off all body text and let the compile settings handle when to indent and not indent. It’s hands-off pure writing, you write paragraph, you don’t get in there and waste time assigning styles to this or that, or worry about having to swap assignments around whenever you move a scene or paragraph within that scene.

In short I’d say if you use Scrivener more simply, as it was designed to be used, you may find yourself doing far less work. The more you try to control it, and micromanage styles and such, the more work you make for yourself, and the more friction you might run into since you’re basically using it against the grain, so to speak.

People that just type in the editor, without styling every paragraph, and let the stock settings do what they do, get flattened indents automatically, without ever thinking about.

1 Like

If you go through all of the different checkboxes in the Text Layout pane and observe their output in the CSS pane, you’ll see that having that degree of control over each style would lead to a lot of permutations.

It’s better to just leave this up to the user’s own CSS if they need to do something very unusual.

That’s not the same thing as stopping the first line indent.

That’s what the text-indent CSS attribute does, actually.

I meant first-paragraph indent. I thought that was the context.

I give up! I’ve wasted weeks on this, including reading almost the entire manual. Scivener 3 is unreliable, at least on my machine. I try to save Format Layout changes, save and it doesn’t update. At least I can see it’s not saving from the preview without having to do a compile.

I’ve tried:
Cold reboot
uninstall and reinstall
uninstall and reinstall on a different hard drive.

It was working yesterday. There are no words.

(fast forward a few more frustrating hours)
Hmm. I created a new format and that worked. Trying to get a blank line after chapter titles seemed to cause problems. Seems like anything in suffix made things go haywire. Once I created a new format I could save changes again.

Since I couldn’t add a line at the end of the titles, I added one for the chapter text. Then the option to skip indent after blank line did a flatten indent for all my chapters. A blank line in my back matter did the trick, too. Note even one space or a non-centered paragraph break doesn’t work. There were some that worked and others that didn’t. So I copy-pasted the whitespace that worked into the ones that didn’t and that solved the indents on the back matter.

All of it works here. All of it. I’m a Mac user, but I can run the Windows version under Parallels, and nearly everything works there, too. Next time you have a question, Zoom me. Trying to work things out here is – as surely you’ve noticed – very difficult.

Zoom me

1 Like

The proper way to add spacing in an ebook (and well, just about anything for that matter) is to do so with formatting, not by inserting empty paragraphs as it sounds like you may be doing. The easiest way to do that is to go into the Section Layout where headings are printed (or ideally, the Style being used to format headings, and then apply the style in Section Layout), put the cursor into the heading line you want to add space to, and use the line height and spacing button on the far right of the Format Bar (you may need to widen the window a bit to see it), selecting “Other” at the bottom of the dropdown menu.

From there you can add spacing after the paragraph (or heading in this case, the terminology for a technical paragraph in word processing is different from a grammatical paragraph). 72pts is an inch, for frame of reference. “Inches” are a bit meaningless in ebooks, but the result should be fairly close to the intention at 100% zoom on the ereader device.

Lastly, given your screenshots above, it looks to me as though you are approaching this in the hardest way possible, by creating a new compile format from scratch rather than using the stock “Ebook” format (in the left sidebar) as a starting point. That, for example, already introduces a space between major headings and the initial paragraph, so you wouldn’t even have to be doing anything yourself here.

That is all fine if you’re looking to learn things inside out and start from a vanilla place so as to have maximum control over everything—but for most people just looking for results, it will be a lot easier to start from “Ebook” and tweak that, here and there.

I’ve always thought it made sense to perfect a pdf before any other format, because it’s easier to quickly “proof” it after every compile (often a one-minute glance). At the end, I can use the very same compile format for all export file types without change.

A post was split to a new topic: Title in editor header bar is too small