Font styles removed from formatting when you close/re-open app

Scrivener on Windows

Summary: Scrivener does not retain font styles such as “Light” or “Black” when you close/re-open the app. Everything that was previously set to one of these styles is set to either Regular or Bold the next time you open the app.

Link to download Roboto fontset, which includes Light & Black styles, for testing:,300i,400,400i,500,500i,700,700i,900,900i

This example uses “Light” but I believe the same is true for any font styles other than Bold or Italics (for example, “Black”)

I set my “Normal” style to:
Font: Roboto
Font Style: Light

I have Project Settings->Formatting: New Documents set to use style Normal. As such, about 99% of what I write is in this font. And that works fine UNTIL I exit Scrivener.

When I next re-open Scrivener, My "Normal " style has changed from Light to Regular:
Font: Roboto
Font Style: Regular

Which means that 99% of my text displays as Regular, rather than Light, because it’s all set to Normal style. Plus, of course, anything new I type comes out as Regular, rather than Light.

Every time, I re-define Normal to be Light and then it’s fine until I exit/re-open.

I realize this is a bit obscure – but because I need to use larger fonts on my laptop, and a lot of them tend to look bold when you scale them up in Scrivener, I’ve been trying to find a thin font that will be comfortable to stare at for long periods of time whether I’m on my laptop (scaled up) or desktop. I found that Roboto Light works great for this.

I did try using the Font “Roboto Light” (instead of Font: Roboto with Style: Light) and Scrivener does keep that when I exit/re-open. But the problem with doing that is, because Font “Roboto Light” has no Bold option, I’m not able to use Bold.

I’m noticing the problem also exists if you copy/paste a paragraph with a font style of Light or Black.

When you paste it, the font style is changed to Regular or Bold.

Yes, that does not work with a few other quirky issues. Actually, I’m surprised you were able to set a default format for new documents. In my [beta 2.9.06 31 May], the form does not allow me to change the new doc paragraph style nor main text formatting. I believe this might be an issue L &L knew about going into this beta version. So we should see a fix in the new release next week. :smiley: :smiley: :smiley:

Oh that would be SOOO amazing!!

Yeah, that dropdown list for New documents use paragraph style: is kind of weird, it seems to be disabled (if you click on it, nothing happens). However, if you specifically click the down arrow, it does allow you to change the style.

I assume you’re talking about the Project defaults. It does update the default font for the project, it just doesn’t display it until you exit and re-enter the application. Bug has been reported, and I think there’s a bug number on it.

Another possible problem, however, is that if you have a different style set in Options for the editor, the first paragraph of your document may show in that font instead of in your default font.