Font suddenly all red

Hello! When I opened Scrivener this morning, the font on my projects is all red now. One project I was editing and should have some parts in red, as I was doing revision mode, but the whole manuscript is in red now. I opened another project that was not in any revision mode and that one is entirely red too. I’m not sure why/how this happened or how to fix it. Thoughts? I’d really like to be able to keep parts of my first project in red (the edited parts) but have the rest be in the normal black color.

Hi :slight_smile:


I tried that and everything is still red :woman_shrugging:t3:

Are you able to set a chunk of your text that is not a revision to black ?

Stupid question, but did you hit “OK” or “Apply” in the options earlier ?

Did you play with themes recently ?

I hit apply and then ok; I also haven’t played with the themes recently. The only way I have been able to change the font color so far is by selecting a paragraph of text then going to Format > Revision Mode > Remove Revisions (on sections I haven’t gotten around to editing yet). I could just do that for the entire manuscript I guess but then I’d lose track of this round of editing.

At this point, I wouldn’t opt for that, since the fact that not only the whole of your project is messed up, but another project as well, means something is really wrong.

What if you step out of revision mode (Alt+0), then close and reopen the project ?
(Try creating a new project as well, with revisions off.)

Meanwhile, I am bringing this to @AmberV’s and @kewms’ attention.

I was able to change most of the document (except for one folder) back to what it was before and preserve the edits by going to File > Options > Editing > Formatting and then highlighting the text sample and changing that color to black. But one folder still has the red font color and that didn’t work on my other project that’s having this issue. :woman_shrugging:t3:

That shouldn’t have worked. Changing the formatting in the options should only affect documents created after the change was made. Not pre-existing documents.
Nothing remotely like what you just described.
Something is wrong.

Was the demo text red in the options/formatting before you changed it ?

Yes it was in red. I’m not sure why it worked either because I really didn’t think it would make any difference. I stepped out of revision mode, like you suggested, and closed and reopened both projects but no dice. Still can’t change the color.

Are you using styles ?

Here is what I think you should do:

1- Make sure revision mode if off
2- Go back to options/formatting, make sure the text is black
[EDIT] Actually, not black, but : image

3- Select all of the documents from your draft in the binder
4- (Note that if you have parts of your text formatted without using styles, that formatting will be lost at this step. Don’t do it if that is the case.)

Would be a good idea to first backup your project if not done already.

I also recommend that you do not open other projects until this is fixed.

That other project might be using its own formatting.
Once the general problem is fixed, that’ll be easy to correct.

For the moment, it seems as if Scrivener can’t keep track of your documents creation date, or something the like.
And that by some very strange process, it keeps “adapting” them to your default formatting. Which is definitely not supposed to happen.

I’m not using any styles. I tried the Documents > Convert > Text to Default Formatting and that worked okay, but there is still one document in each project that won’t change it’s font color.

Perhaps it has the revision color ?
Select the text, then

That seemed to work, thank you for all your help! I’m not sure if there’s anything I need to do to make sure this doesn’t happen again, or to my other projects I haven’t opened yet? Maybe I should start a new fake project and see what the formatting looks like?

Well… technically, once fixed it shouldn’t happen again.
It shouldn’t have happened to begin with.

I’m thinking your default text color perhaps was red all along, but for some reason (possibly something outside of Scrivener – a Windows’ setting (?)) it only displayed as its true color recently.

If a project simply refuses to revert to black, see if it is rather using this formatting:


Either fix the color there, or untick the checkbox I am pointing to if you are certain your project has no special formatting that differ from the one set in the options.
And then redo the “convert to default formatting” steps as I explained earlier above.

All of this doesn’t answer the question as to why/how your default formatting’s font color applied to your pre-existing documents (from red to black) without you converting them to default formatting.
(Unless you actually did that step and just didn’t mention it? (I mean in your fourth post.))
Otherwise @AmberV will most likely want to look into this…

There is a known bug that causes strange issues with default formatting getting applied to text that already exists. It seems particularly so where the formatting is itself something kind of odd to be having as a default in the first place.