Fontgeeky question about Courier Italic

Apologies if this has been covered or is a n00b eejit question: I’ve looked and can’t find it.

I like to default work in Courier, but – I think because Courier’s Italic font is called ‘Oblique’, not Italic – when I select Text>Font>Italic in Courier, the ‘Italic’ option is ghosted and can’t be selected. And command-I does nothing, either. Does anyone else have this problem? I have to go via Text>Font>Show Fonts, and select ‘Oblique’, which is obviously a royal faff to have to do every time.

I’ve got an easy workaround, having installed the (almost identical… almost) Courier Final Draft, which sensibly calls its version ‘Italic’, and which Scrivener can therefore find no problem. However, in my fontgeekiest moments I confess that I miss the fractionally thicker strokes of Original Flavour Courier, and wonder therefore if there’s some way I can persuade Scrivener to see its ‘Oblique’ as Italic, and therefore let me keyboard-access it at a stroke of command-I.

Any suggestions?

For me both the font menu and cmd+i works fine with Courier (the original one that came with the OS and which internally is named oblique).

I doubt that this could be a Scrivener problem. Scrivener uses the Apple TextEngine. What happens when you try Courier italics in another app that uses it, say, in TextEdit?

zomg! Thanks, you’re right, same problem with TextEdit. No idea what’s going on. Looks like I need a tame Mac-geek to help technodumb me. If anyone can parachute in with a suggestion, it’ll be gratefully received. Otherwise, so’s not to clog up the forum, I’ll take this elsewhere…

Cheers.

I’m definitely not that Geek person, but nonetheless two things more from me:

  1. I use Linotype FontExplorer X (last free version) for font management. I don’t have the slightest idea if that would change the Courier behaviour but maybe you would like to give it a shot.

  2. I found out that one way to screw up the OS font handling is a font family that contains more than just the four fonts normal, bold, italic, and bold-italic. The result would not be like in your case that there is no reaction when you switch between the different states of the font (technically these are a number of fonts, logically it is normal/plain plus bold and or italic) but a confusion when you want to switch back to normal.

[size=50]3) The font palette does display the italic font, doesn’t it? It didn’t get deleted or deactivated by any chance?[/size]

Simple. You have either a font conflict going on or you have the wrong courier active (check font book for duplicates). Many times some applications install their “own” version of a font (Micorsoft is notorious for this) and sometimes they instal their own standard fonts like Times or Courier. You may have another COurier active and the original Courier that came with the OS turned off OR Font book has them both turned on and there is a “duplicate” or conflicting font and so some of the font family variants may be disabled.

Check your Font Book and look for any • next to any fonts or fonts that are turned off.

Go down to Courier and see if you have more than one or if one is grayed out. TUrn off all the COuriers then turn on one set and use text edit to check if using italics works. If it doesn’t turn OFF that courier and turn on the other one (if there is more than one). Check again.

Also highlight any font with a • and select RESOLVE duplicates in Font Book.

Hope that helps